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Introduction
Overview
Welcome to ShadowProtect Granular Recovery for Exchange™6.1, the mailbox recovery
software that saves time, money, and resources when recovering Microsoft® Exchange Server
data.

ShadowProtect Granular Recovery for Exchange (SPGRE) works with your existing Microsoft
Exchange Server backup architecture and procedures, and allows you to recover individual
mailboxes, folders, messages, attachments, calendar items, notes, and tasks directly to your
production Microsoft Exchange Server or any PST file. This eliminates time-consuming and
expensive single mailbox (brick-level) backups. This powerful software also lets you search and
create a copy of all archived email that matches a given keyword or criteria.

Five Major Reasons for Using SPGRE
There are five primary ways you can benefit from using SPGRE:

Minimize the time to restore an individual mailbox. SPGRE can slash restore time, making it
possible to restore mail items from a previous full backup directly into your production Microsoft
Exchange Server, or directly into a new or existing PST file. This eliminates the need for a recovery
server and the extra steps required to separately import mail back into Microsoft Exchange
Server or Microsoft® Office Outlook®.

Eliminate backups of an individual mailbox. SPGRE eliminates the need to back up individual
mailboxes because they can be restored directly from an EDB file.

Minimize the time to locate all email matching specific criteria. SPGRE includes an Advanced
Find feature that can search across all mailboxes in an archive EDB file, rather than searching
one mailbox at a time or bringing an old backup back online for analysis. And you can search by
a variety of criteria, including keywords, subject, date and specific users.

Minimize storage space and the cost required to store and archive your backups. Because you
don't need to back up mailboxes individually doing a brick-level backup, you eliminate the
backup space, cost, and time associated with performing brick-level backups.

Minimize the time to back up all mailboxes. SPGRE eliminates the need to back up mailboxes
individually. Normally, companies do a full Microsoft Exchange Server backup, and then run a
second process to back up "Very Important Mailboxes" (VIMs) individually as well. SPGRE
eliminates this second process.

Keyboard Shortcuts

1



Introduction

Menu Bar Keyboard Shortcut

File Menu

Open Source Ctrl+S

Open Target PST Ctrl+T

Open Target Microsoft Exchange Server Ctrl+E

Close Store Ctrl+L

User Data Wizard Ctrl+W

Exit Alt+F4

Edit Menu

Copy Selection to Clipboard Ctrl+C

Paste Copied Item(s) Ctrl+V

Paste Special Ctrl+Y

Delete DEL

Rename Ctrl+R

New Folder Ctrl+N

New Mailbox Ctrl+M

Move To Folder (Microsoft Exchange Server as a target - Find window) Ctrl+Shift+V

Cut (Microsoft Exchange Server as a target - Find window) Ctrl+X

View Menu

2



Introduction

Menu Bar Keyboard Shortcut

Refresh Screen F5

Tools Menu

Integrity Check Ctrl+I

Export Ctrl+P

Create Reports Ctrl+Q

Find F3

Online Help

View Help F1

About the Microsoft Exchange Server Database
The Microsoft Exchange Server database consists of the following files:

n .edb file (rich text database file) contains data placed in the store through Messaging
Application Programming Interface (MAPI), as well as all the database tables that define
mailboxes, messages, folders, and attachments.

n .stm file (streaming database file) contains common Internet formatted content, such as
Multipurpose Internet Mail Extensions (MIME) content, that protocols other than the MAPI
protocol place in the store.

Note: The .stm file is new to Microsoft Exchange Server 2000. Microsoft Exchange Server
5.5 does not contain .stm files.

n .log files (transaction logs) are history files recording server activity. These files are useful in
restoring and backing up Microsoft Exchange Server data. Transaction logs for Microsoft
Exchange Server 5.5, 2000, and 2003 are 5 MB in size. Transaction logs for Microsoft
Exchange Server 2007 and Microsoft Exchange Server 2010 are 1 MB in size.
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Each storage group uses its own set of transaction log files. For example, if a storage
group contains five stores, all transactions for all five stores are recorded in a single series
of transaction log files. You can determine where to locate the transaction log files for
each storage group.

n .chk (check) files are checkpoint files used for recovering (playing) data from transaction
logs into EDB files. The checkpoint is the place marker in the EDB.CHK file that indicates
which transactions have been committed. Whenever data is written to an EDB file from
the transaction log, the EDB.CHK file is updated with information specifying that the
transaction was successfully committed to the respective EDB file. Separate Exx.chk files
are maintained for each storage group using ESE (Extensible Storage Engine).

n .pat (patch) files are used to record information on page splits in Microsoft Exchange
Server 5.5 through Microsoft Exchange Server 2000 (SP1). In Microsoft Exchange Server 2000
(SP2) and later, the functionality provided by .pat files is incorporated into Microsoft
Exchange Server log files.

Organizing the Microsoft Exchange Server Database Files for
ShadowProtect
For best results when using an online incremental or differential backup

n Put the .edb, .stm, and .pat files in one directory.
n Put the associated log files (for example, .log, .chk) in one directory.

Note: The two directories can be different.

SPGRE does not require .stm or .log files, but you should include them to ensure that all email
data is recovered. You may get corruption errors if these files are not present.

If you are using an offline backup

You need to use the .edb and .stm files for offline backups. To ensure that all email data is
recovered, you should also include all .log files, as well as .pat and .chk files if they exist. SPGRE
performs its own verification process and includes the .log and .pat files to determine if it needs
them to recover the data.

Readme File
The ShadowProtect Granular Recovery for Exchange (SPGRE) Readme file contains additional
information about the ShadowProtect Granular Recovery for Exchange (SPGRE), including:

n System requirements
n Installing and uninstalling ShadowProtect Granular Recovery for Exchange (SPGRE)
n Licensed agents
n Upgrading from previous versions (if applicable)
n Known issues

4



Introduction

n Technical support
n License agreement

The ShadowProtect Granular Recovery for Exchange (SPGRE) Readme file is included on the
installation CD and in the electronic package.

Getting Help
StorageCraft Technology Corporation provides you with the following ways to get help with
SPGRE: "Online Help" and "Technical Support".

Online Help
Online Help includes all of the information in the user guide and more, and it lets you quickly
access this information by using one of three tabs. The Contents tab offers a hierarchical view of
the contents of the user guide. The Search tab offers a full-text search of the user guide. The
Index tab offers a keyword-based way to get to specific topics.

To start online Help
Do one of the following:

n On the Help menu, click Contents.

n Click on the toolbar.
n Press the F1 key.

To identify a tool or control

n Position the pointer over a tool or control, and then pause. A tool tip shows the name of
the item.

Technical Support
If you have questions or problems not answered in the user guide or the online Help (F1), call our
Technical Support group. When reporting an issue, please include any information that might
help us diagnose the problem. The following details are often the most helpful:

n The version of SPGRE you are using (on the Help menu, click About).
n The versions of the Windows® operating systems and Microsoft Office Outlook that you are

running.
n The version of Microsoft Exchange Server that contained the source EDB file.
n The circumstances and sequence of steps that led to the problem.
n The text of the error messages (if any appeared), and the contents of the Details window.
n A list of other Windows-based programs that you were running when the error occurred.

See “Contact Information” at the beginning of this user guide.
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Conventions in this Manual
This manual uses guidelines for documenting menu commands and shortcuts; commands
available on shortcut menu; and notes and tips.

Menu Commands and Shortcuts
This manual uses the following conventions for documenting menu commands and shortcuts:

Example Describes

On the File menu, point to Target PST,
and then click Create New.

Choosing the Create New command on the
Target PST submenu on the File menu.

On the Edit menu, click Paste Special. Choosing the Paste Special command on the Edit
menu.

PressCtrl+S (Open source EDB) Holding down the Ctrl key and the S key at the
same time and then releasing them.

Right-click Clicking the right mouse button.

Shortcut Menu
You can access many of the same commands available on the menu bar and toolbar by right-
clicking the mouse to display a shortcut menu. The contents of the shortcut menu depend on
whether you right-click in the source or target pane. This manual seeks to teach you how to use
commands on the menu bar and toolbar, and doesn't always specify when you can use the
shortcut menu. Once you become familiar with SPGRE, the commands available to you on the
shortcut menu should become apparent.

Notes and Tips
The notes and tips in this user guide follow the guidelines offered in the Microsoft Manual of Style
for Technical Publications, 3rd Edition. Redmond, WA: Microsoft Press, 2004.
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Chapter 1: Looking at the Interface
Overview
This chapter describes the parts of the main window of ShadowProtect Granular Recovery for
Exchange (SPGRE) and shows you how to preview messages, view details of an EDB, PST, or CAS
file, and change the view.

Main Window
The main window is where you do most of your work. This window displays the source EDB, PST, or
CAS file(s) as well as the target PST file(s), Microsoft Exchange Server or CAS. The target acts as a
container for the restored files. The various work areas and controls are described in the following
sections.

Note: In the illustration below, the target pane displays a PST that acts as a container for restored
files. Keep inmind that the target pane could just as easily display aMicrosoft Exchange Server.

Figure 1-1: The main windowwith four panes
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Chapter 1: Looking at the Interface

Source Pane
The source pane displays the data you intend to recover, such as the EDB file(s) or a content
analysis store (CAS). The source pane can also display one or more PST files if you have
purchased the "PST as Source File" agent.

Figure 1-2: Sample icons with descriptions below

Sources Root Node contains one or more source data stores that are pre-
pended with a “SourceX” where X is a number starting with 1 and is
incremented for each additional source opened. You can select the sources
root node as your search source.

Source EDB File (for example, ) contains the Microsoft
Exchange Server Information Store data. Click the plus sign (+) next to an EDB
file to expand its contents.

Mailbox (for example, ) contains the Microsoft Office Outlook
folders. Click the plus sign (+) next to a mailbox to expand its contents.

Microsoft Office Outlook Folders (for example, Inbox, Contacts,
Tasks) contain Microsoft Office Outlook message items. Select a folder to view
its contents in the source message list.

Source CAS File (for example, ) contains the content analysis store
data created to analyze content based on certain criteria.
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Chapter 1: Looking at the Interface

CAS Profile Folder (for example, ) which contains the results
of a content analysis.

Inaccessible Mailboxwhich displays if a mailbox is inaccessible.

An inaccessible mailbox will present no visible content. Target mailbox access
is controlled by the target Microsoft Exchange Server.

Note: In the above illustration, the source pane displays an EDB file, but it could just as easily
display a PST file, CAS, or evenmultiple EDB and PST files.

Source Message List
The source message list displays the message items in the Microsoft Office Outlook folder that
you selected in the source pane. This folder is one of the Microsoft Office Outlook folders (for
example, Inbox, Contacts, Tasks). In the illustration below, the source message list displays the
messages in an Inbox.

Figure 1-3: The Source Message List

The source message list displays metadata about the message items in six columns. The
metadata includes file type; attachments, if any; message sender; subject; date; and status. The
Sent Items folder also displays the "To" column. For more information on the message list, see
"Sorting Messages in the Message Lists" on page 16.

The source content analysis store message list includes file type; Database #, Database, and
Path. The source content analysis store profile folder message list includes file type; Attachment,
if any; From; Subject; Create Date; Database #; Folder, and Status. For more information on
content analysis stores, see "Content Analysis Store" on page 121.
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Target Pane
The target pane can display one or more target PST files and/or one target mailbox, public
folders and mailboxes from a Microsoft Exchange Server, and content analysis stores (CAS) with
profile folders. The target acts as a container for your restored files. If a target is a newly created
PST file, it defaults to 10 Microsoft Office Outlook folders. If a target is an existing PST file or
Microsoft Exchange Server, it shows whatever folders are in the target. It is into these folders that
you paste and restore your message items. For information on restoring message items, see
"Restoring Microsoft Exchange Server Data" on page 85.

Target Panes for PST files Target Pane for a CAS file Target Pane for a Microsoft
Exchange Server

Figure 1-4: Target panes with PST, CAS, andMicrosoft Exchange Server files

Target Message List (Restored Messages)
The target message list displays the message items in the Microsoft Office Outlook folder that
you selected in the target pane. If the target is a newly created PST file or CAS, the Outlook
folders and message list will be empty. If the target is an existing PST file, CAS file, or Microsoft
Exchange Server, or if you have restored message items to a newly created PST file, you can
select a folder in the target pane to display messages in the target message list.
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Figure 1-5: Target Message List displaying restoredmessages

The target message list displays metadata about the message items in five columns (instead of
six columns in the source message list). The metadata includes file type; attachments, if any;
message sender; Subject; and Create Date. The Sent Items folder also displays the "To" column.
For more information on the message list, see "Sorting Messages in the Message Lists" on page
16.

The target content analysis store message list includes file type; Database #, Database, and
Path. The target content analysis store profile folder message list includes file type; attachment,
if any; From; Subject; Create Date; Database #; Folder; and Status. For more information on
content analysis stores, see "Content Analysis Store" on page 121.

Menu Bar

Figure 1-6: The Menu Bar in the main window

The menu bar contains all of the commands for SPGRE. The menu commands, submenu
commands, and resulting windows are discussed fully in the chapters that focus on those specific
commands. See the Index to quickly locate the pages on which a menu command is discussed.

Toolbar

Figure 1-7: The Button Toolbar in the main window

The buttons on the toolbar perform the following functions:

Open Source displays the Open window, which lets you
navigate to and select a source Microsoft Exchange
Server Database (EDB), PST, or CAS file. The EDB, PST, or
CAS file contains the message items you want to restore.
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Open Target PST displays the Open window, which lets you
navigate to and select a target Personal Folders (PST) file.
The target PST file is a container for restored message
items.

Open Target Microsoft Exchange Server displays the
Connect to Exchange Server window, which lets you
connect to a target Microsoft Exchange Server. The
target Microsoft Exchange Server is a container for
restored message items.

Create/Open Content Analysis Store displays the Create
Content Analysis File window which allows you to open an
existing content analysis store or to create a new one in
the target pane.

Copy copies into the Clipboard the selected message(s)
in the source message list; or the selected folder, mailbox,
or EDB file in the source pane.

Paste inserts the items from the Clipboard into the
selected folder in the target pane. If you want to retain
the directory structure of the restored messages, you must
use the Paste Special command instead of the Paste
command or Paste button.

Export displays the Export window, which lets you export
messages to a local or network drive destination. You can
choose to save exported messages as plain text files (.txt)
or as Microsoft Office Outlook files (.msg). You can also
export EDBs to a PST.

Search displays the Find window, which lets you specify
the desired search criteria for finding messages in the
source pane.

Preview Pane displays the Preview pane on the SPGRE
main window so you can read a message without
opening it.

View Help displays SPGRE Online Help, which includes all
of the information in this user guide and more. Online Help
lets you quickly access this information by using a
Contents, Search, or Index tab.
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Message Table View is only available when a message in
the source message list is highlighted. It opens a Message
Table View of that message and any message related to
it.

Attachment Table View is only available when a message
with an attachment in the source message list is
highlighted. It opens an Attachment Table View of that
message and attachment and all related messages and
attachments.

Conversation View is only available when a message in
the source message list is highlighted. It shows the thread
of that message with indentations to indicate the
responses to each e-mail.

Previewing and Opening Messages
In the Preview pane, you can read the contents of a message item and open attachments. You
can preview a message located in either the source message list or the target message list. The
information displayed in the Message Header is different for messages, calendars, contacts,
tasks, and distribution lists.

To open the preview pane
Do one of the following:

n On the View menu, click Preview Pane.

n On the toolbar, click the Preview Pane icon in the toolbar.

To hide the preview pane

n Repeat one of the previous steps.

Tip: Hiding the Preview pane will allow you to scroll through messages faster.

To display a message in the preview pane

1. In the source or target message list, select a message.

2. Open the Preview pane by clicking on the Preview Pane icon in the toolbar.
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Figure 1-8: Preview pane for amessage

To open a message in its own window

n In the source or target message list, double-click a message.

Opening Attachments
If you have the appropriate program installed on your computer, SPGRE will load the application
to view the selected attachment (for example, to view an .xls file attachment, SPGRE will launch
Microsoft® Excel®).

If no associated program is available for the attachment's file type, SPGRE presents a message
window saying the attachment cannot be viewed.

Note: SPGRE cannot view attached embedded graphics in HTMLmessages.

To open an attachment in an open message

1. In the message list, double-click a message that has the Attachment icon next to its
name.

2. Click the Attachment icon on the right side of the message header. A pop-up window
lists the attachments for the selected message.

3. Click the name of the attachment you want to view.

To open an attachment in the preview pane

1. In the message list, select a message that has the Attachment icon next to its name.

2. Open the Preview pane. In the SPGRE main window, click the Preview Pane icon . In
the Find window, select the Preview check box.

3. Click the Attachment icon on the right side of the message header in the Preview
pane. A pop-up window lists the attachments for the selected message.

4. Click the name of the attachment you want to view.
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Saving Attachments
A "save attachments" option is available on the File menu and paperclip menu of an open
message, as well as on the paperclip menu of the Preview pane. The Save Attachments window
lists the attachments for the selected message and lets you select the attachments you want to
save.

To save attachments in an open message

1. In the source or target message list, double-click a message that has the Attachment icon
next to its name.

2. In the open message, do one of the following:
l On the File menu, click Save Attachments.

l Click the Attachment icon on the right side of the message header, and then click
Save Attachments.

3. In the Save Attachments window, select one or more attachments, and click OK.
4. In the Browse For Folderwindow, select a location for the attachment(s), and click OK.

To save attachments in the preview pane

1. In the source or target message list, select a message that has the Attachment icon
next to its name.

2. In the Preview pane, click the Attachment icon on the right side of the message
header, and then click Save Attachments.

3. In the Save Attachments window, select one or more attachments, and click OK.
4. In the Browse For Folderwindow, select a location for the attachment(s), and click OK.

Changing the View
You can change the view in the ShadowProtect Granular Recovery for Exchange (SPGRE)
window by hiding the toolbar or status bar, by using split bars; by sorting message lists; and by
refreshing the screen.

Viewing or Hiding the Toolbar and Status Bar
The toolbar and status bar appear by default in the main SPGRE window, but you can easily hide
them.

To hide the toolbar or status bar

n On the View menu, click Toolbar or Status Bar. The check mark no longer appears next to
the name of the toolbar or status bar.

15



Chapter 1: Looking at the Interface
To view the toolbar or status bar

n On the View menu, click Toolbar or Status Bar. The check mark appears next to the name
of the toolbar or status bar.

Resizing Panes Separated by a Split Bar
You can use a split bar (the horizontal or vertical double line that separates two panes) to
increase the area within one pane while simultaneously decreasing the area within the adjacent
pane. The source pane, source message list, target pane, target message list, and Preview pane
all border a split bar.

To resize panes separated by a split bar

1. Position the cursor over a split bar between two panes until a double arrow appears. A
vertical double arrow appears if you position the cursor over a horizontal split bar.

Figure 1-9: Before dragging the split bar between the target message list and the Preview
pane

2. Drag the split bar until the two panes are the desired size.

Sorting Messages in the Message Lists
You can sort messages in the source and target message lists based on attachments, message
sender, subject, date, and status. In addition, the source message list lets you sort messages
based on status, and the Sent Items folder lets you sort items based on the "To" heading. Sorting
messages on the From column, for example, can help to identify messages from a specific
sender.

To sort a message list

1. Click a column heading to sort the messages based on that heading. For most headings,
an arrow appears indicating the sort direction. An up arrow indicates that the messages
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appear in ascending (A-Z) order. A down arrow indicates that the messages appear in
descending (Z-A) order.

2. To reverse the order of the messages based on that column heading, click the column
heading again. Notice the arrow reverses directions.
An example of sorting messages :

l If you click the attachment column heading, messages are sorted in ascending
order based on this heading, even though no arrow appears. This means that
messages with attachments appear at the top of the message list, while messages
with no attachments appear at the bottom of the document list. If you click the
attachment column heading again, the order is reversed.

Note: The view settings (sort order and columnwidth) for a folder or mailbox are saved until you
close the data store.

Refreshing the Screen
You may want to refresh the screen occasionally when you are connected to a target Microsoft
Exchange Server. That is because the information on the server may change while you are
connected.

To refresh the screen
Do one of the following:

n On the View menu, click Refresh.
n Press the F5 key.

Viewing the Properties of an EDB File, PST File,
CAS File, CAS Profile Folder, Folder, or Mailbox
SPGRE makes it easy to view the properties of a source PST file, EDB file, CAS file, CAS profile
folder, mailbox, or folder.

Note:Only accessible mailboxes can produce property reports. For CAS files, inaccessible
mailboxes within that data store are not included in the totals.

Note:When the Show Recoverable Items (Microsoft Exchange Server 2010) preference is
enabled, the Recoverable Items folder, subfolders, andmessages will appear in the folder and
message counts in the EDB properties. If the preference is cleared, the Recoverable Items
folders andmessages are not included in the folder andmessage counts.

To view the properties

1. In the source pane, right-click an EDB file, PST file, CAS file, CAS profile folder, mailbox, or
folder.

2. On the shortcut menu, click Properties. A Properties dialog box appears.
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Figure 1-10: EDB File Properties dialog box

3. Click Save to save the Microsoft Exchange Server name to your hard drive.

Figure 1-11: Properties of a PST File
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Figure 1-12: Properties of a Content Analysis Store (CAS) File

Figure 1-13: Properties of a Content Analysis Store (CAS) Profile Folder

Figure 1-14: Properties of a Content Analysis Store (CAS) Profile Folder
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Figure 1-15: Properties of aMailbox

An alternate way to view the properties of an EDB or PST file

Once you have viewed the properties of the source EDB or PST file as described above, you can
then display the properties in the Preview pane.

1. Open the Preview pane by clicking the Preview Pane icon on the toolbar or by clicking
the View menu and pointing to Preview Pane.

2. Right-click on the source EDB or PST file in the source pane and click Properties.

Figure 1-16: Properties of an EDB File

Performing an Integrity Check
You can perform an integrity check on messages, folders, mailboxes, PST files, CAS files, CAS
profile folders, EDB files, and live Microsoft Exchange Server target search results. During the
integrity check, SPGRE verifies that it can read all folder and message properties from the
selected source.

To perform an integrity check

1. In the source pane, select an EDB file, PST file, CAS file, CAS profile folder, mailbox, folder,
or message(s).
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2. Do one of the following:
l On the Tools menu, click Integrity Check. The Integrity Check window appears.
l Right-click the item and click Integrity Check in the shortcut menu.

3. Click Print to print a copy of the integrity check.
4. Click Save to save a copy of the integrity check to file.

Viewing Deleted Messages
SPGRE can view and restore deleted messages that are held in the EDB file. These messages
appear under the Status column in the source message list. If deleted messages have been
purged from the EDB file due to the deleted retention schedule, SPGRE cannot view or restore
these messages.

Content analysis store deleted messages in both the source and target panes also appear under
the Status column in the message list.

Viewing Deleted Items in Microsoft Exchange Server 2010
Databases
Deleted items do not have the same functionality as items from earlier databases. Instead of
being stored in the folder they were deleted from, they are stored in a separate folder called
"Recoverable Items."

By default, this separate folder is not displayed in the source tree under the mailbox. A
preference setting allows you to display this folder in the source tree making the deleted items
accessible to you. See Setting Preferences in the "Security Tab" on page 23 for more information.

Recoverable Items Folder
When the Recoverable Items folder is visible to you, the subfolders are accessible as well
including:

n Deletions: The Deletions folder holds messages that have been removed from the Inbox
using the Delete key, menu item, or shortcut key.

n Purges: The Purges folder holds messages that have been removed from a mailbox via the
"Recover Deleted Items" tool in Microsoft Office Outlook when a legal hold is set for a
mailbox.

n Versions: The Versions folder holds sent and received messages that were edited by a user
in a mailbox for which a legal hold was set.

You are able to perform source operations on the messages, including copying and exporting.
The message in Recoverable Items and its subfolders are also included in searching, creating
reports, integrity checks, and property counts.

Note: The displaying of Recoverable Items in Microsoft Exchange Server 2010 applies to sources
only. They are not visible in target mailboxes.
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Setting Preferences
The Preferences dialog box allows you to streamline SPGRE operations. Most of the preference
settings in the three tabs are selected by default. There are two exceptions: the "Display new PST
when PST limit is reached" setting in the Options tab, and the "Enable Tamper-Proof Target"
setting in the Security tab. If you change the settings, they are stored and reloaded on the next
run of SPGRE.

To change preference settings

1. On the Edit menu, click Preferences.
2. Select or clear the check boxes in the three tabs, as desired.

Options Tab

Figure 1-17: The Options tab in the Preferences dialog box

n Run Data Wizard on startup: The Data Wizard will launch every time you open SPGRE.
n Create new PST folders when PST message/folder limits are reached: SPGRE will

automatically create new folders (for example, Inbox) when the 16,383 messages/folder
limit is reached. After SPGRE creates a new folder, it continues to restore Microsoft
Exchange Server data where it left off. For more information, see "Limits for PST and Folder
Targets" on page 86.

n Check for duplicate messages during copy: When restoring Microsoft Exchange Server
data, SPGRE does not copy duplicates of a message to the destination folder if a message
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already exists in the destination folder. Selecting this preference setting results in slower
copy performance.

n Check for duplicate messages during search: SPGRE will not return duplicates of a
message during a search. For example, if the same message exists in two or more data
stores, only the first message found is listed in the search results. Selecting this preference
setting results in slower search performance.

n Display new PST when PST limit is reached: When the limit for a PST is reached in the target
pane, SPGRE automatically displays the overflow PST.

n Allow mailbox creation during copy: If this option is selected and a mailbox copy is
initiated by you, mailboxes can be created during a mailbox copy. If it is cleared, mailbox
creation cannot take place during copy. This setting has no effect on manual mailbox
creation.
l Prompt whether to create mailboxes during copy: If this option is selected, you are

prompted at the beginning of a copy and are asked if mailboxes should or should not
be created. When it is cleared, mailbox creation occurs automatically. This setting is
only in effect whenAllow mailbox creation during copy is enabled. This setting has no
effect on manual mailbox creation, or during a single mailbox copy.

n License file name: This box displays the current location of the license file. To put this file in
a different location, click Browse and navigate to the desired location. There are two
ways to manage the location of the license file:
l Multiple Copies of SPGRE: Put one license file in the SPGRE program directory of each

SPGRE installation.
l Single Copy of SPGRE: Put one license file in a single network folder to which all SPGRE

installations make reference.

Note: For more information about the license file, see "The License File" in the Readme
file.

Security Tab
The options in this tab are modifiable by default only by users that belong to the Administrator
Group. The options are stored in the registry: HKEY_LOCAL_
MACHINE\SOFTWARE\StorageCraft\ShadowProtect GRE.

The SPGRE Installation program sets this registry key to have read/write access to users in the
Administrators group and read-only access by any user in the Users group.

23



Chapter 1: Looking at the Interface

Figure 1-18: The Security tab in the Preferences dialog box

n Allow preview of messages: If this option is not selected, you will not have the ability to
open or preview messages in the source or target.

n Enable Tamper-Proof Target: If this option is selected, SPGRE does not allow you to delete
messages or folders in the target or have the ability to rename folders in the target. You
only have the ability to add (copy) to the target.

n Allow Bcc field to be included when restoring or searching messages: If this option is
selected, SPGRE includes Bcc information when restoring or searching messages. This
means that a recipient is able to see Bcc recipients that he or she was not intended to
see. It also means that searching with the "Sent to" option returns messages for Bcc
recipients.

n Enable Message Views: If this option is selected, it makes the Message Views available.
n List inaccessible mailboxes: If this option is selected, the inaccessible mailboxes listed in

the directory are shown. They are for display only.
n Show Recoverable Items (Microsoft Exchange Server 2010): Selecting this option allows

the "Recoverable Items" folder to be displayed under your mailbox, enabling you to have
access to any deleted items. It also provides access to the "Purges" and "Versions" folders,
which are also sub-folders of "Recoverable Items."

Important: Selecting the Show Recoverable Items (Microsoft Exchange Server 2010)
preference causes your Microsoft Exchange Server 2010 EDB sources to close. A warning
message appears giving you the option to cancel or continue changing the setting.
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Warnings Tab

Figure 1-19: The Warnings tab in the Preferences dialog box

n Show warning when logs specified but not found: SPGRE warns you when opening an EDB
file if no .log files were found at the specified directory.

n Show warning when no log file path specified: SPGRE warns you when opening an EDB file
if a .log file path has not been specified.

n Show warning when copying to Microsoft Exchange Server root: SPGRE warns you when
you are about to copy a large amount of data to the Microsoft Exchange Server root.

n Show warning when opening a Microsoft Exchange Server and a Microsoft Exchange
Server is already open: This warning appears when you attempt to connect to either a
single mailbox or all mailboxes on a Microsoft Exchange Server when a target Microsoft
Exchange Server connection is already open in SPGRE.
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Overview
You can open a source Microsoft Exchange Server Database (EDB) file or PST file and specify a
target PST file or target Microsoft Exchange Server by using one of the following methods:

n Use the Data Wizard.
n Open the source database and target mailboxes from the ShadowProtect Granular

Recovery for Exchange (SPGRE) main window.

Note: You cannot open the same PST file as both source and target.

Using ShadowProtect Data
In order for SPGRE to operate fully, you must first mount a ShadowProtect image file containing
the data you wish to open. For more information on mounting image files, refer to the
ShadowProtect software documentation.

Running the Data Wizard
The Data Wizard guides you through the loading of the Microsoft Exchange Database (EDB), PST
files, or content analysis store (CAS) files into SPGRE, and shows you how to specify the target PST
file or Microsoft Exchange Server.

Data Wizard: Welcome Page
The first time you start ShadowProtect Granular Recovery for Exchange (SPGRE), the Data Wizard
launches.

To manually start the Data Wizard

1. Click Start, and then point to Programs. Point to ShadowProtect Granular Recovery for
Exchange (SPGRE) and select . The Data Wizard appears.
Note: If you do not want to run the DataWizard every time you start ShadowProtect
Granular Recovery for Exchange (SPGRE), clear the Show wizard on startup check box.

2. Click Next.
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Data Wizard: Source Path Selection
On the Source Path selection page of the Data Wizard, specify the source EDB file path along
with its log file path and temporary file path; or specify the source PST file or CAS file path. If you
do not want to open a source EDB, PST, or CAS file at this time, click Skip.

Note: Due to the database nature of the PST file andMAPI subsystem, PSTs opened as source are
modified.

To specify a source file

1. In the Source File box, click Browse to find the source EDB file, source PST file, or source
CAS file.

2. If you specified a PST or CAS file path, proceed to step 5. PST files do not require log file or
temporary file paths.

3. In the Log File Path box, click Browse to find the log files associated with the source EDB file.

Important: After you select an EDB file, the Log File Path box defaults to the source EDB file
path, even if the log files are not in the same directory as the source EDB file. Therefore,
make sure you enter the correct log file path in the Log File Path box.

4. In the Temporary File Path box, accept the default location for .idx and .dat files, or specify
a new location if they require more hard drive space. For more information, see
"Guidelines for Selecting a Microsoft Exchange Server Database" on page 28.

5. If you want to view a filtered display of mailboxes in the Source Pane, use the Mailbox
Criteria (optional) box. For more information, see "MailboxCriteria" on page 34.
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Figure 2-1: Browse to the EDB or PST file to use as source

6. Click Next.

Guidelines for Selecting a Microsoft Exchange Server
Database

1. For the best results when using an online incremental or differential backup:
l Put the .edb, .stm, and .pat files in one directory.
l Put the associated log files (for example, .log, .chk) in one directory.

Note: The two directories can be different.

Note: SPGRE does not require .stm or .log files, but you should include them to ensure that
all email data is recovered

2. If you are using an offline backup: You need to use the .edb and .stm files. To ensure that
all email data is recovered, you should also include all .log files, as well as .pat and .chk
files if they exist. SPGRE performs its own verification process and will include the .log and
.pat files to determine if it needs them to recover the data.

3. For best results when specifying a temporary file path for .idx and .dat files: Make sure you
have a sufficient amount of hard drive space for .dat and .idx files. These files may require
hard drive space equal to the size of the .log files. Therefore, you may need to change the
default file path for .idx and .dat files if you need more space.

28



Chapter 2: Using ShadowProtect Granular Recovery for Exchange
(SPGRE)

SPGRE never modifies an .edb file or its associated files (for example, .log, .stm, .pat,
.chk); however, it does create .dat and .idx files the first time you open an .edb file from a
directory that contains log files. Each time you reopen the .edb file, SPGRE uses the
information in the .dat and .idx files to open the .edb file more quickly.

Note:Microsoft Exchange Server 5.5, 2007, and 2010 do not use .stm files.

Data Wizard: Target Type and Path Selection
On the Target Type and Path Selection page of the Data Wizard, specify the type and path of
the target file you are using as the container for your restored data. You have four choices: 1)
specify a PST file as the target for restored data; 2) specify a Microsoft Exchange Server single
mailbox connection as the target for restored data; 3) specify a Microsoft Exchange Server all
mailboxes connection as the target for restored data; or 4) specify a Content Analysis Store
(CAS) file as the target for creation or processing. An option to open Public Folders is available
upon connection to a Microsoft Exchange Server.

Note: Click Skip if you do not want to select a target file at this time.

To specify a PST File as the target for restored data

1. Select the PST File option.

Figure 2-2: Select the PST File option in the Target Type & Path Selection window

2. Do one of the following:
l If you know the target PST file path, type it in the Target PST File path box.
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l Click Browse to open the Create PST File window, and navigate to the desired
location. Then create a new PST file by typing a name in the File name box, or select
an existing PST file. Next, click Open. The path of the target PST file appears in the
Target PST File path box.

3. Click Next.

To specify a Microsoft Exchange Server as the target for restored data for a single
mailbox

1. Select the Connect to Exchange Server (Single Mailbox) option.

Figure 2-3: Selecting Connect To Exchange Server (Single Mailbox) brings up the target
Microsoft Exchange Server section.

2. For Mailboxand Server Name boxes, type the mailbox and server names.

Tip: If you do not know the full name of the mailbox, type the first letter of the mailbox in
theMailboxName box, and click Next. In the Check Name window that appears, select
the mailbox from the list, and clickOK.

3. The Connect to Public Folders check box is selected by default. This feature allows you to
open public folders as a target for restoring public folders or messages. If you do not want
to restore to public folders, clear this check box. For more information, see "Restoring to
Public Folders" on page 96.
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4. If you are not connected to a domain, the Enter Password window appears. In this window,
type a user name that has full rights to the mailbox, a password, and a domain name. Then
click OK. This window may appear again, which will require you to reenter this information.

5. Click Next.

To specify a Microsoft Exchange Server as the target for restored data for All Mailboxes

1. Select the Connect to Exchange Server (All Mailboxes) option.

Figure 2-4: Selecting Connect To Exchange Server (All Mailboxes) brings up the target
Microsoft Exchange Server section.

2. For Domain Controller and Server Name boxes, the domain controller and server names
auto-populate.

Note: For Microsoft Exchange Server 2010, specify the name of the Client Access Server
(CAS) that provides access to the mailboxes you want to access (not the mailbox server,
unless the mailbox server has the client access role installed).

3. The Connect to Public Folders check box is selected by default. This feature allows you to
open public folders as a target for restoring public folders or messages. If you do not want
to restore to public folders, clear this check box. For more information, see "Restoring to
Public Folders" on page 96.

4. If you are not connected to a domain, the Enter Password window appears. In this window,
type a user name that has full rights to the mailbox, a password, and a domain name. Then
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click OK. This window may appear again, which will require you to reenter this information.
5. Click Next.

To specify a content analysis store

1. Select the Content Analysis Store option.

Figure 2-5: Select Content Analysis Store in the Target Type & Path Selection

2. Do one of the following:
l If you know the target CAS file path, enter it in the Content Analysis Store Path box.
l Click Browse to open the Create Content Analysis File window, and navigate to the

desired location. Then create a new CAS file by typing a name in the File name box, or
select an existing CAS file. Next, click Open. The path of the target CAS file appears in
the Content Analysis Store Path box.

3. Click Next.

Data Wizard: Now Processing Data File
The Now Processing Data File page of the Data Wizard reports the processing of the EDB file in
three stages: pre-scanning the log files (integrity check); scanning the log files (i.e., playing the
log files); and hashing the EDB file (building a folder hierarchy).

When the processing is complete, SPGRE automatically proceeds to the next page.
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Note: If SPGRE encounters bad or missing log files during log playing, you will be given the option
to continue without playing the logs. If you choose to continue, SPGRE processes the EDB
without logs.

Data Wizard: Completing the Data Wizard
On the last page of the Data Wizard, click Finish. This page of the Data Wizard displays the
source file results and the target file results.

Looking at the Main Window after Using the Data Wizard
In the SPGRE main window, the source and target panes now contain a source EDB file, PST file,
CAS, target PST file, a target Microsoft Exchange Server, or target CAS.

Source pane with a PST file Source pane with an EDB file Source pane with CAS files

Figure 2-6: Source panes with PST, EDB, andCAS files

33



Chapter 2: Using ShadowProtect Granular Recovery for Exchange
(SPGRE)

Target pane with a PST file Target pane for a Microsoft
Exchange Server

Target pane with CAS files

Figure 2-7: Target panes for PST files, Microsoft Exchange Server, and CAS file

Returning to the Data Wizard
When working in the main window, you can return to the Data Wizard at any time.

To open the Data Wizard from the main window

n On the File menu, click Use Wizard.

Opening the Source Database and Target
Mailboxes from the Main Window
Instead of using the Data Wizard to open the source databases and target mailboxes, you can
open them from the main window.

Mailbox Criteria
When selecting the EDB Source Files, you can use the "Mailbox Criteria (optional)" box to limit the
number of mailboxes that are opened and displayed in the Source Pane. This box appears on
the Select Source Files dialog box (opened from the File menu Open Source command) or the
Source Path Selection page of the DataWizard.

When you enter a string in the Mailbox Criteria box, SPGRE matches your entry against the display
name and alias of the mailboxes to select data in the source database. Only mailboxes
matching your entries are displayed on the Source Pane.

The mailbox criteria uses a simple "string contains" match and is not case sensitive. You can use a
semi-colon to separate and enter multiple strings. If you want to include a semi-colon in one of
your entries, use double quotes around that entry.

Mailbox criteria only works with mailbox stores, it does not work with public folder stores. If you use
mailbox criteria on a public folder store, it will not be used and all public folders will be opened.

Note: Anymailboxes which do not match the entered string will not appear in the Source Pane
andwill not be included in any subsequent tasks, such as searching, copying, and exporting of
the entire database.

Opening Source and Target Files
The File menu and toolbar can be used to open source or target files in addition to the Data
Wizard.
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To open a source file

1. Do one of the following:
l On the File menu, click Open Source.

l On the toolbar, click the Open Source icon .

Important: Before you select a source EDB file in the window below, see "Guidelines for
Selecting a Microsoft Exchange Server Database" on page 28.

Figure 2-8: Browse to an EDB, PST, or CAS file to use as source

2. In the Source File box, click Browse to find a source EDB, PST, or CAS file. The CAS files are
used for the content analysis store feature.

3. If you selected a PST or CAS file, proceed to step 6. PST and CAS files do not require log file
or temporary file paths.

4. In the Log File Path box, click Browse to find the log files associated with the source EDB file.

Important: After you select an EDB file, the Log File Path box defaults to the source EDB file
path, even if the log files are not in the same directory as the source EDB file. Therefore,
make sure you enter the correct log file path in the Log File Path box.

5. In the Temporary File Path box, accept the default location for .idx and .dat files, or specify
a new location if they require more hard drive space. For more information, see
"Guidelines for Selecting a Microsoft Exchange Server Database" on page 28.

6. If you want to view a filtered display of mailboxes in the Source Pane, use the Mailbox
Criteria (optional) box. For more information, see "MailboxCriteria" on page 34.
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7. Click OK. The EDB or PST file appears in the SPGRE source pane.

Figure 2-9: Source pane for an EDB file

Tip: You can use Windows Explorer to open an EDB, PST, or CAS file. In Windows Explorer,
double-click the file or drag into the SPGRE source pane.

To open an existing target PST

1. Do one of the following:
l On the File menu, point to Open\Create Target, thenOpen Target PST, and click Open

Existing.

l On the toolbar, click the Open Target PST icon .
2. In the Open Existing PST window, navigate to the desired location, and select an existing

PST file.
3. Click Open. The PST file appears in the SPGRE target pane.

Tip: In Windows Explorer, you can drag a PST file into the SPGRE target pane. Note that
double-clicking a PST file does not open it when using Windows XP, Microsoft Office
Outlook XP, or Microsoft Office Outlook 2003.

To create a new target PST

1. On the File menu, point to Open\Create Target, thenOpen Target PST, and click Create
New.

2. In the Create PST File window, navigate to the desired location. You may want to create a
new folder.

3. In the File name box, type a name for the new PST file.
4. Click New. The PST file appears in the SPGRE target pane.

Note:WithMicrosoft Office Outlook 2003, you have to choose between the 97 and 2003
version of the PST.
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Figure 2-10: Target pane for a PST file

To open a target Microsoft Exchange Server

1. Do one of the following:
l On the File menu, point to Open\Create Target, then click Open Target Exchange

Server.

l On the toolbar, click the Open Target Exchange Server icon . The Connect to
Exchange Serverwindow appears.

Figure 2-11: Enter the Mailbox Name and Server Name to connect to the Microsoft
Exchange Server

2. For the Mailbox and Server Name boxes, type the mailbox and server names.

Tip: If you do not know the full name of the mailbox, type the first letter of the mailbox in
the MailboxName box, and click OK. (Log on to the Microsoft Exchange Server if
prompted; see step 4.) In the Check Name window that appears, select the mailbox from
the list, and click OK.
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3. The Connect to Public Folders check box is selected by default. This feature allows you to
open public folders as a target for restoring public folders or messages. If you do not want
to restore to public folders, clear this check box. For more information, see "Opening
Source and Target Files".

4. If you are not authenticated to the domain, the Enter Password window appears. In this
window, type a user name that has full rights to the mailbox, a password, and a domain
name. Then click OK. This window may appear again, which requires you to reenter this
information.

5. Click OK. The Microsoft Exchange Server appears in the SPGRE target pane.

Figure 2-12: Target pane for aMicrosoft Exchange Server

To open a target content analysis store

1. Do one of the following:
l On the File menu, point to Open\Create Target, then click Open Target Content

Analysis Store.

l On the toolbar, click the Open Target Content Analysis Store icon . The Opening a
Content Analysis File window appears.

2. In the Opening a Content Analysis File window, navigate to desired location and select an
existing CAS file.

3. Click Open. The CAS file appears in the SPGRE target pane.

Opening a Live Microsoft Exchange Server as a Target
You can open live Microsoft Exchange Servers as a target within SPGRE. This means you can
connect to one live Microsoft Exchange Server at a time, establishing a single mailbox
connection or connecting to all accessible mailboxes and displaying a list of the mailboxes
found in that Microsoft Exchange Server. A status indicator tells you if you have permission rights
to view a mailbox.
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Note: The Microsoft Exchange Server as a target feature is only supported if the system running
SPGRE is on the same domain as the Microsoft Exchange Server.

Recommendation: If connecting to a Microsoft Exchange Server 2010 CAS Array, use the fully
qualified domain name of the CAS Array for the Server Name (for example,
casarray.domain.name).

Mailbox Access
When connecting to a single mailbox, the target pane populates with only the specified single
mailbox. When connecting to all mailboxes on a Microsoft Exchange Server, the target pane
populates with the list of mailboxes found in that Microsoft Exchange Server.

Note: You can connect to only one live Microsoft Exchange Server at a time. If you attempt to
connect to an additional live Microsoft Exchange Server while a server is already open, the
current server connection closes.

Preference Setting
When SPGRE connects to a Microsoft Exchange Server, it can display both accessible and
inaccessible mailboxes. You can set the preferences so that all mailboxes are displayed
regardless of their permission status or only those mailboxes that you are permitted to view. See
"Setting Preferences" on page 22 for more information.

Figure 2-13: List inaccessible mailboxes preference

Note: Clearing this option while you have mailboxes open prompts the mailbox list to refresh and
redisplay without the inaccessible mailboxes showing.
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Mailbox Functions
Paste, Paste Special, folder creation, folder renaming, and the search functions are available for
the accessible mailboxes. A mailbox or server cannot be renamed.

To open a single mailbox in a live Microsoft Exchange Server as a target

1. Do one of the following to display the Connect To Exchange Serverwindow:
l On the File menu, click Open\Create Target, then click Open Target Exchange Server.

l On the toolbar, click the Open Target Exchange Server icon .

Figure 2-14: Connect To Exchange Server

2. Under Connect options, click Connect to a single mailbox.
3. Enter Exchange Information:

l MailboxName: The mailbox name must match exactly what is in the Microsoft
Exchange Server.

l Server Name: The Server Name must match the existing Microsoft Exchange Server.
4. Select Connect To Public Folders if desired.
5. Click OK. The Opening Target process begins. This may take several minutes.
6. The Opening Target progress report can be printed or saved if desired. Otherwise, click

Close to close the progress window and display the opened mailboxes in the target pane.

To open mailbox(es) in a live Microsoft Exchange Server using the Data Wizard

1. Open the Data Wizard by doing one of the following:
l On the File menu, click Use Wizard.
l PressCtrl+W.

2. Click Next and then Skip to reach the Target Type & Path Selection page.
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Figure 2-15: Connect To Exchange Server using the DataWizard

3. Select Connect To Exchange Server (Single Mailbox) or Connect To Exchange Server (All
Mailboxes).

4. Do one of the following:
l For Single Mailbox, using the drop-down arrows, select the correct MailboxName and

Server Name.
l For All Mailboxes, using the drop-down arrows, select the Domain Controller and Server

Name.
5. Select or clear Connect To Public Folders as desired.
6. Click Next. The Opening Target progress window is displayed. If Microsoft Office Outlook

does not recognize the Mailbox Name, aCheck Name window appears.
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Figure 2-16: Check Name

7. Select a new Mailbox Name from the Change to list and click OK. The connection
completes and the Completing the Data Wizard page appears.

8. Click Finish.

To open multiple mailboxes in a live Microsoft Exchange Server as a target

1. Do one of the following to display the Connect To Exchange Serverwindow:
l On the File menu, click Open\Create Target, and then click Open Target Exchange

Server.

l On the toolbar, click the Open Target Exchange Server icon .
2. Under Connect options, click Connect to all mailboxes on server.
3. Enter Exchange Information:

l Domain Controller: The domain controller is needed to retrieve the list of mailboxes
from Active Directory. It must match the existing Microsoft Exchange Server.

l Server Name: The Server Name must match the existing Microsoft Exchange Server.

Note: For Microsoft Exchange Server 2010, specify the CAS or the CAS Array for the Server Name.

4. Select Connect To Public Folders if desired.
5. Click OK. If the server is already open, a message appears asking you if you want to close

the current server and continue.
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Figure 2-17: Exchange Server already openmessage

Tip: If you do not want this message to display every time you already have aMicrosoft
Exchange Server open, select Do not show this message again. Selecting this option
clears the Showwarning setting in Preferences - Warnings tab.

Figure 2-18: Clearedwarning message

Clicking OK in the Microsoft Exchange Server already open message begins the Opening
Target process. This may take several minutes.

6. If you want to stop the opening process from completing, click Cancel. A cancel
confirmation message appears. Until you click Yes or No, the opening process continues in
the background.

Note: If you click Yes to confirm the cancel operation, all mailboxes opened up to this
point appear in the target pane after the progress window is closed.
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7. The Opening Target progress report can be printed or saved if desired. Otherwise, click
Close to close the progress window and display the opened mailboxes in the target pane.

Opening Multiple Sources and Targets
You can display multiple sources in the source pane and multiple targets in the target pane.
sources include EDB, PST, and CAS files. Targets include PSTs, CAS, and Microsoft Exchange
Servers. See the instructions for using the Data Wizard or the main window to open one source or
one target at a time.

Multiple sources Multiple targets

Figure 2-19: Multiple sources and targets can be displayed

Closing Sources and Targets
You can close sources and targets from the SPGRE main window.

To close a source

1. In the source pane, select a source EDB, PST, or CAS file.
2. Do one of the following:

l On the File menu, click Close Store.
l Right-click the selection, and on the context menu click Close Store.

To close all sources

1. In the source pane, right-click the sources root node.
2. On the context menu, click Close All Stores.

To close a target

1. In the target pane, select a PST file, Microsoft Exchange Server database, or CAS file.
2. Do one of the following:
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l On the File menu, click Close Store.
l Right-click the selection, and on the context menu click Close Store.

Deleting Items in the Target Pane
Using the Delete key to remove an item (for example, folder, message) from the SPGRE target
pane permanently deletes the item, similar to using Shift+Delete in Microsoft Office Outlook.

Note:Messages within a content analysis store profile folder cannot be deleted.

Using the Mailbox Creation Wizard
You can create new mailboxes either by using a wizard or the Copy and Paste functions. Possible
uses for this new function are migrating user accounts from Microsoft Exchange Server 2000 or
2003 to a Microsoft Exchange Server 2007 or Microsoft Exchange Server 2010 target or archiving
legacy data.

User Permission
You must have the necessary Active Directory permissions to create a mailbox on the selected
Microsoft Exchange Server. Both the user account logons and the Name field must be unique to
create a new user account and mailbox. If you are creating a mailbox for an existing user, the
Name field must match the full name of the existing user.

Tip: It is recommended that anyone creating mailbox-enabled users have fundamental
knowledge of Microsoft Exchange Server administration and Active Directory.

Creating Mailboxes
You can create mailboxes with the wizard manually or by copying a single mailbox or the root of
a source EDB onto the root of a target Microsoft Exchange Server.

Note:Mailbox creation on disabled user accounts is not supported.

Note: The target Microsoft Exchange Server must be in the same domain as the SPGRE
computer.

Creating Mailboxes Using the Wizard
You can create a new mailbox by using the wizard which steps you through the process.
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To create a Microsoft Exchange Server 2000/2003 mailbox using the wizard

1. Open a target Microsoft Exchange Server in SPGRE.
2. Right-click the target Microsoft Exchange Server root and click New Mailbox, or on the Edit

menu, click New Mailbox. The New Mailbox form appears.

Figure 2-20: NewMailbox form for Microsoft Exchange Server 2000 and 2003

3. Enter the User Information:
l Organizational unit: This field is pre-populated but you can change it by clicking

Browse.
l First name: (Optional) Enter the first name of the user. If a user account already exists

without a mailbox based on this Name, the mailbox is created on the existing user
account.

l Initials: (Optional) Enter the initials of the user.
l Last name: (Optional) Enter the last name of the user. If a user account already exists

without a mailbox based on this Name, the mailbox is created on the existing user
account.

l Name: This field auto-populates as the First name, Initials, and Last name are entered.
This field can also be modified.

l User logon name (User Principal Name): Create a user logon name for the new
account. If this name matches the same field of an existing user account, an error is
displayed indicating that it is a duplicate.
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l UPN suffix: This field adds the Organizational Unit selected as the second half of the
logon name email address.

l User logon name (pre-Windows 2000): A user logon name for older versions of
Windows.

l Password and Confirm Password: (Optional) The password must meet the domain's
minimum password requirements.

l Save as default password: Select this check box to designate the entered password as
the default.

4. Click Next to display the Mailbox Settings window.

Figure 2-21: Mailbox Settings window for Microsoft Exchange Server 2000 and 2003

5. Ensure the Storage group andMailbox database settings are correct. The Alias and Server
fields are auto-populated, however, Alias can be edited if necessary.

6. Click Finish.
7. If the mailbox creates successfully or unsuccessfully, a message displays. Click OK. If it was

created successfully, the new mailbox automatically appears in the target directory and is
expanded.
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To create a Microsoft Exchange Server 2007 mailbox using the wizard

1. Open a target Microsoft Exchange Server in SPGRE.
2. Right-click the target Microsoft Exchange Server 2007 root and click New Mailbox, or on

the Edit menu, click New Mailbox. The New Mailbox form appears.

Figure 2-22: NewMailbox form for Microsoft Exchange Server 2000, 2003, and 2007

3. Enter the User Information:
l Organizational unit: This field is pre-populated but you can change it by clicking

Browse.
l First name: (Optional) Enter the first name of the user. If a user account already exists

without a mailbox based on this Name, the mailbox is created on the existing user
account.

l Initials: (Optional) Enter the initials of the user.
l Last name: (Optional) Enter the last name of the user. If a user account already exists

without a mailbox based on this Name, the mailbox is created on the existing user
account.

l Name: This field auto-populates as the First name, Initials, and Last name are entered.
This field can also be modified.

l User logon name (User Principal Name): Create a user logon name for the new
account. If this name matches the same field of an existing user account, an error is
displayed indicating that it is a duplicate.
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l UPN suffix: This field adds the Organizational Unit selected as the second half of the
logon name email address.

l User logon name (pre-Windows 2000): A user logon name for older versions of
Windows.

l Password and Confirm Password: (Optional) The password must meet the domain's
minimum password requirements.

l Save as default password: Select this check box to designate the entered password as
the default.

4. Click Next to display the Mailbox Settings window.

Figure 2-23: Mailbox Settings for multiple mailboxes -Microsoft Exchange Server 2007

5. Enter the Mailbox Settings:
l Enter the Alias for the mailbox user. The alias will be derived from each source mailbox.
l The Server field is auto-populated. Ensure the Storage group andMailbox database

settings are correct.
l Mailbox database: The mailbox database will be automatically selected by the

Microsoft Exchange Server if not specified. To specify the mailbox database, select the
check box which enables the drop-down list of all available mailbox databases.

l Managed foldermailbox policy: To apply a managed folder policy to your mailbox,
select the check box which enables the drop-down list of all available managed
folder mailbox policies in the organization.
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l Exchange ActiveSync mailbox policy: To apply an ActiveSync mailbox policy to your
mailbox, select the check box which enables the drop-down list of all available
ActiveSync mailbox policies in the organization.

6. Click Next. The mailbox information is validated and the mailbox is created.
Note: If the Managed folder mailbox policy check box is selected, a warning appears
stating: "When assigning amanaged folder mailbox policy with managed custom folders
to amailbox, Microsoft Office Outlook clients older thanMicrosoft Office Outlook 2007 do
not have all available client features and clients older thanMicrosoft Office Outlook 2003
SP2 are not supported. Are you sure you want to assign amanaged folder mailbox policy
to this mailbox?"

To create a Microsoft Exchange Server 2010 mailbox using the wizard

1. Open a target Microsoft Exchange Server in SPGRE.
2. Right-click the target Microsoft Exchange Server 2010 root and click New Mailbox, or on

the Edit menu, click New Mailbox. The New Mailbox form appears.

Figure 2-24: NewMailbox form for Microsoft Exchange Server 2010

3. Enter the User Information:
l Organizational unit: The Organizational Unit will be automatically selected by the

Microsoft Exchange Server if not specified. You can change it by selecting the Specify
the Organizational unit rather than using a default one check box. Select this check
box to enable the Browse button where you can select a different Organizational unit.

l First name: (Optional) Enter the first name of the user. If a user account already exists
without a mailbox based on this Name, the mailbox is created on the existing user
account.

l Initials: (Optional) Enter the initials of the user.
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l Last name: (Optional) Enter the last name of the user. If a user account already exists
without a mailbox based on this Name, the mailbox is created on the existing user
account.

l Name: This field auto-populates as the First name, Initials, and Last name are entered.
This field can also be modified.

l User logon name (User Principal Name): Create a user logon name for the new
account. If this name matches the same field of an existing user account, an error is
displayed indicating that it is a duplicate.

l UPN suffix: This field adds the Organizational Unit selected as the second half of the
logon name email address.

l User logon name (pre-Windows 2000): A user logon name for older versions of
Windows.

l Password and Confirm Password: (Optional) The password must meet the domain's
minimum password requirements.

l Save as default password: Select this check box to designate the entered password as
the default.

4. Click Next to display the Mailbox Settings window.

Figure 2-25: Mailbox Settings window for Microsoft Exchange Server 2010

5. Enter the Mailbox Settings:
l Enter the Alias for the mailbox user.
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l Mailbox database: The mailbox database will be automatically selected by the
Microsoft Exchange Server if not specified. To specify the mailbox database, select the
check box which enables the drop-down list of all available mailbox databases.

l Managed foldermailbox policy: To apply a managed folder policy to your mailbox,
select the check box which enables the drop-down list of all available managed
folder mailbox policies in the organization.

l Exchange ActiveSync mailbox policy: To apply an ActiveSync mailbox policy to your
mailbox, select the check box which enables the drop-down list of all available
ActiveSync mailbox policies in the organization.

6. Click Next. The mailbox information is validated. The Archive Settings page appears.
Note: If the Managed folder mailbox policy check box is selected, a warning appears
stating: "When assigning amanaged folder mailbox policy with managed custom folders
to amailbox, Microsoft Office Outlook clients older thanMicrosoft Office Outlook 2007 do
not have all available client features and clients older thanMicrosoft Office Outlook 2003
SP2 are not supported. Are you sure you want to assign amanaged folder mailbox policy
to this mailbox?"

Figure 2-26: Archive Settings for Microsoft Exchange Server 2010

7. Select the Create an archive mailbox for this account to associate an online archive
mailbox with the user account.

Note:
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l If your Preferences are set to display inaccessible mailboxes, they are displayed in the
target directory but are inaccessible.

l If the mailboxwas created successfully but it cannot be connected to, the new
mailbox is displayed in the target directory as inaccessible.

l If the mailbox creation fails, the mailbox does not appear in the target directory.

Creating Mailboxes Using Copy-Paste
You can create new mailboxes by using the Copy function. Mailbox creation through copying
can be made available or unavailable through the Preferences dialog box under the Options
tab.

To create a new Microsoft Exchange Server 2000/2003/2007/2010 single mailbox using
copy-paste

1. Verify that Allow mailbox creation during copy option in Preferences is selected.
2. Right-click the single mailbox in the source pane and click Copy.
3. Highlight the target Microsoft Exchange Server and click Paste. The New Mailboxwindow

opens with certain fields auto-populated.

Note: If Paste is not available, you do not have access rights to the source mailbox.

4. Confirm the User Information settings are correct and click Next.
5. Confirm Mailbox Settings are correct and click Finish. The Copy Progress window displays

and creates a report when the copying is finished.
6. Click Print to print the report, Save to save the report to your hard drive, or Close to close

the Copy Progress window. Each mailbox from the source EDB you copied is now a new
mailbox in the target pane.

Note:

l If the mailbox already exists and is accessible, it is added to the target directory and
shown as accessible.

l If the source mailbox did not exist in the target directory, a new mailbox is created on
either a new user account or an existing user account.

l If the mailbox you just created is not accessible, it displays in the target directory and
shown as inaccessible.

To create multiple Microsoft Exchange Server 2000 and 2003 mailboxes using copy-paste

1. Verify that Allow mailbox creation during copy and Prompt whether to create mailboxes
during copy options in Preferences are selected.

2. Right-click the entire source EDB and click Copy.
3. Highlight the target Microsoft Exchange Server and click Paste. A confirmation message

appears.
4. Clicking Yes opens the mailbox creation wizard.
5. Confirm the User Information settings are correct. You can specify the Organizational Unit,

UPN Suffix, and Password. The other fields will be derived from each source mailbox.
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6. Click Next.

Figure 2-27: User Information window for multiple mailboxes

7. Confirm that the Mailbox Settings are correct. The Alias will be derived from each source
mailbox.
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Figure 2-28: Mailbox Settings for multiple mailboxes

8. Click Finish. The Copy Progress window appears and creates a report when the copying is
finished.

9. Click Print to print the report, Save to save the report to your hard drive, or Close to close
the Copy Progress window.
The EDB source you copied is now a new mailbox in the target pane.

To create multiple Microsoft Exchange Server 2007 mailboxes using copy-paste

1. Verify that Allow mailbox creation during copy and Prompt whether to create mailboxes
during copy options in Preferences are selected.

2. Right-click the entire source EDB and click Copy.
3. Highlight the target Microsoft Exchange Server and click Paste. A confirmation message

appears.
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Figure 2-29: MailboxCreation confirmationmessage

4. Clicking Yes opens the mailbox creation wizard.
5. Confirm the User Information settings are correct. You can specify the Organizational Unit,

UPN Suffix, and Password. The other fields will be derived from each source mailbox.

Figure 2-30: User Information window for multiple mailboxes

6. Click Next. The Mailbox Settings window appears.
7. Enter the Mailbox Settings:

l Enter the Alias for the mailbox user. The alias will be derived from each source mailbox.
l The Server field is auto-populated. Ensure the Storage group andMailbox database

settings are correct.
l Mailbox database: The mailbox database will be automatically selected by the

Microsoft Exchange Server if not specified. To specify the mailbox database, select the
check box which enables the drop-down list of all available mailbox databases.

l Managed foldermailbox policy: To apply a managed folder policy to your mailbox,
select the check box which enables the drop-down list of all available managed
folder mailbox policies in the organization.
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l Exchange ActiveSync mailbox policy: To apply an ActiveSync mailbox policy to your
mailbox, select the check box which enables the drop-down list of all available
ActiveSync mailbox policies in the organization.

Figure 2-31: Mailbox Settings for multiple mailboxes -Microsoft Exchange Server 2007

8. Click Next. The mailbox information is validated and a new mailbox is created.
Note: If the Managed folder mailbox policy check box is selected, a warning appears
stating: "When assigning amanaged folder mailbox policy with managed custom folders
to amailbox, Microsoft Office Outlook clients older thanMicrosoft Office Outlook 2007 do
not have all available client features and clients older thanMicrosoft Office Outlook 2003
SP2 are not supported. Are you sure you want to assign amanaged folder mailbox policy
to this mailbox?"

9. Click Finish. The Copy Progress window appears and creates a report when the copying is
finished.

10. Click Print to print the report, Save to save the report to your hard drive, or Close to close
the Copy Progress window.
The EDB source you copied is now a new mailbox in the target pane.

To create multiple Microsoft Exchange Server 2010 mailboxes using copy-paste

1. Verify that Allow mailbox creation during copy and Prompt whether to create mailboxes
during copy options in Preferences are selected.
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2. Right-click the entire source EDB and click Copy.
3. Highlight the target Microsoft Exchange Server and click Paste. A confirmation message

appears.
4. Clicking Yes opens the mailbox creation wizard.
5. Confirm the User Information settings are correct. You can specify the Organizational Unit,

UPN Suffix, and Password. The other fields will be derived from each source mailbox.

Figure 2-32: User Information window for multiple mailboxes

6. Click Next. The Mailbox Settings window appears.
7. Enter the Mailbox Settings:

l Enter the Alias for the mailbox user. The alias will be derived from each source mailbox.
l Mailbox database: The mailbox database will be automatically selected by the

Microsoft Exchange Server if not specified. To specify the mailbox database, select the
check box which enables the drop-down list of all available mailbox databases.

l Managed foldermailbox policy: To apply a managed folder policy to your mailbox,
select the check box which enables the drop-down list of all available managed
folder mailbox policies in the organization.

l Exchange ActiveSync mailbox policy: To apply an ActiveSync mailbox policy to your
mailbox, select the check box which enables the drop-down list of all available
ActiveSync mailbox policies in the organization.
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Figure 2-33: Mailbox Settings for multiple mailboxes -Microsoft Exchange Server 2010

8. Click Next. The mailbox information is validated. The Archive Settings page appears.
Note: If the Managed folder mailbox policy check box is selected, a warning appears
stating: "When assigning amanaged folder mailbox policy with managed custom folders
to amailbox, Outlook clients older thanMicrosoft Office Outlook 2007 do not have all
available client features and clients older thanMicrosoft Office Outlook 2003 SP2 are not
supported. Are you sure you want to assign amanaged folder mailbox policy to this
mailbox?"
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Figure 2-34: Archive Settings for Microsoft Exchange Server 2010

9. Select the Create an archive mailbox for this account to associate an online archive
mailbox with the user account.

10. Click Finish. The Copy Progress window appears and creates a report when the copying is
finished.

11. Click Print to print the report, Save to save the report to your hard drive, or Close to close
the Copy Progress window.
The EDB source you copied is now a new mailbox in the target pane.

Note:

l If the mailbox already exists and is accessible, it is added to the target directory and
shown as accessible.

l If the source mailbox did not exist in the target directory, a new mailbox is created on
either a new user account or an existing user account.

l If the mailbox you just created is not accessible, it displays in the target directory and
shown as inaccessible.

Preference Settings
Two options have been added to the Options tab of the Preferences dialog box regarding
mailbox creation through copy. See "Setting Preferences" on page 22 for more information.
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n Allow mailbox creation during copy
n Prompt whether to create mailboxes during copy

Licensing Information
License information for the Microsoft Exchange Server database currently in use can be
obtained by right-clicking on the source root in the source pane and selecting Save Licensing
Information.

The file saves into a text format and automatically names it "ServerProperties.txt."
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Overview
The Find in Source window lets you search a source EDB, PST, or CAS file for message items that
are defined by such criteria as keywords, message senders and recipients, and message
creation dates. In addition, this window lets you define the scope of your search: an EDB, PST, or
CAS file, one or more mailboxes or folders (for example, Inbox), dates, or even previous search
results.

The Find in Exchange Server Target window adds the ability to search a live Microsoft Exchange
Server target and perform actions on the search results.

Guidelines for Using the Find Window
n The Find Now button only becomes available if at least one of the following conditions is

met:
l At least one Search in check box is selected.
l The Sent from or Sent to box contains at least one character.
l The Created Dated after or Created Dated before check box is selected.

n Each Search in check box that you select is run as a separate query, and the results of the
query are combined (i.e., OR'd together). For example, if you enter "solution" in the Search
for words box, and then select the Message Subject andMessage Body check boxes,
ShadowProtect Granular Recovery for Exchange (SPGRE) will return message items that
contain "solution" in either the message subject or message body.

n If you select one or more Search in check boxes, but specify no additional search criteria,
SPGRE will return all of the message items in the folder(s) undergoing the search.

n SPGRE can search multiple information stores at the same time. In the Find in Source
window, click Browse and you will see a tree view of all of the open source data stores.
You can then select multiple mailboxes or folders to include in your search.

n SPGRE does not return duplicates of a message item during a search as long as the "Check
for duplicate messages during search" preference is selected. For example, if the same
message item exists in two or more data stores, only the first message item found is listed in
the search results. For more information, see "Preference Settings" on page 60.

n The contents of an inaccessible EDB mailbox cannot be searched.
n Messages in the Microsoft Exchange Server 2010 Recoverable Items folder are included in

search results only if the Show Recoverable Items (Microsoft Exchange Server 2010)
preference is enabled. See "Security Tab" for more information setting preferences.

n If you use the "Mailbox Criteria (optional)" box on the Select Source Files dialog box or the
Source Path Selection page of the DataWizard, only EDB mailboxes containing your entry
(or entries) are displayed on the Source Pane. Any mailboxes which do not match the
entered string(s) will not appear in the Source Pane and will not be included in any
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subsequent tasks (such as searching, copying, and exporting of the entire database). For
more information, see "MailboxCriteria" on page 34.

Searching Sources
The Find in source window provides the ability to search single or multiple mailboxes and perform
actions on the search results.

Tip: CAS and PST files are searchable in the source pane but not in the target pane.

The actions allowed to perform on search results are copying or exporting message items,
performing Integrity Checks, and viewing message items using the Message Views options. You
can have several Find in Source windows open at a time.

To search for message items in sources

1. In the source pane, select the folder (for example, EDB or PST file, mailbox, Inbox) you want
to search. The folder(s) you select defines the scope of your search.

2. Do one of the following:

l Click Find in the toolbar to display the Find in Source window. The name of the folder
you selected appears next to the Search in folder box.

l Right-click the file and click Find.
l On the Tools menu, click Find.
l Press F3

Note: The first time you search for amessage item, the Search in folder option is
automatically selected. For information on using the Search in results option, see
"Searching Within Results" on page 67.

3. To search multiple mailboxes or folders, click Browse. In the Select Folder(s) window, select
the items you want to search. In the illustration below, two mailboxes have been selected.
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Figure 3-1: You can select multiple folders or mailboxes to search.

Note: If you select the Search Subfolders check box, SPGRE includes subfolders in the
search.

4. Click OK to return to the Find in Source window.
In the following illustration, the Search in folder box now displays “Multiple folders
selected.”

Figure 3-2: Result whenmultiple folders are selected
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5. In the Search for words box, enter one or more words or phrases if you want to execute a
keyword search. Keep in mind the following points:
l Put a space between words or phrases to perform an AND operation (i.e., all words

must be matched in order to include a message item with the search results).
l Put a comma between words or phrases to perform an OR operation (i.e., only one of

the words must be matched in order to include a message item with the search
results).

l Put quotation marks around word phrases (i.e., the exact phrase must be matched in
order to include a message item with the search results).

Example: Search for words: dog cat mouse, rat

Search results: Message items that contain ["dog" AND "cat" AND "mouse"] OR
["rat"] are included in the search results.

6. In the Exclude words box, enter words or phrases if you want to perform a NOT operation. If
matched, these words or phrases will exclude a message item from the search results. The
rules for using spaces, commas, and quotation marks apply when excluding words from a
search.

Example: Search for words: dog cat mouse, rat

Exclude words: bird

Search results: Message items that contain ["dog" AND "cat" AND "mouse"] OR
["rat"] BUT NOT ["bird"] are included in the search results.

7. For Search in, select one or more of the following check boxes: Message Subject,
Message Body, Attachment File Name(s), or Attachment Text. Each Search in check box
that you select is run as a separate query, and the results of the query are combined (i.e.,
OR'd together).

Note: SPGRE has the ability to searchmultiple levels of embeddedmessage items. Select
Attachment Text in the Select in check box. See "Searching Embedded Message Items"
on page 66 for more information.

Note about searching within attachments: SPGREdoes not search within archive file types
such as .zip or .rar files. For more information, see "Searching Within Attachments " on page
71.

8. In the Sent from and Sent to boxes, enter the appropriate names, if desired. Using the Sent
to box is particularly useful if you are trying to find a message item sent to multiple people.
The rules for using spaces, commas, and quotation marks apply when using the Sent from
and Sent to boxes.

9. For Created Dated after andCreated Dated before, select the appropriate check box, if
desired. You may select both check boxes. Then type or select the part of the date you
want to change.
l Created Dated after: Searches for documents created on or after the selected date.
l Created Dated before: Searches for documents created on or before the selected

date.
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10. When you have finished specifying search criteria, click Find Now. The results of your search
appear in the message item list.

11. To preview the message items returned by the search, click the Preview check box.

Figure 3-3: Find windowwith results andmessage pane

Searching Embedded Message Items
You can search multiple levels of embedded message items in SPGRE.

Note: Searching attachments (email and non-email) is available only when the Agent for
Advanced Searching for Microsoft Exchange Server is enabled.

To search embedded message items

1. Perform steps 1 through 6 in "Searching Sources" on page 63.
2. For Search in, click Attachment Text.
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3. Continue with step 8 in the "Searching Sources" on page 63process.

Searching Within Results
The Search in results option lets you refine the search process using the previous search results.

To search within results

1. To make the Search in results option available, you must perform at least one search.
2. Modify the search criteria as desired. For information on specifying search criteria, see

"Searching Sources" on page 63.
3. Select the Search in results option at the top left of the Find in Source window.
4. Click Find Now. The results of your new search appear in the message item list.
5. To preview the message items returned by the search, click the Preview check box.

Figure 3-4: Checking the Preview option adds amessage Preview pane
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Viewing Previous Search Results
You can click the Previous button multiple times to return to any previous search criteria and
search results. This button becomes unavailable when there are no more previous results.

To view previous search results

1. Perform at least two searches so the Previous button becomes available.
2. Click Previous. The results of the previous search appear in the in the message item list.
3. You can now view the previous search, or you can modify the search criteria and conduct

a new search. For information on specifying search criteria, see "Searching Sources" on
page 63.

Clearing Fields and Results
If you click the Clear Fields button, all of the search criteria that you entered in the Find in Source
window are returned to the default settings. If you click the Clear Results button, all current and
past search results are cleared.

Searching Microsoft Exchange Server Target
You can search a live Microsoft Exchange Server target and delete, move, copy, or export the
search results. This means you can search and delete, or move specific message items from a
Microsoft Exchange Server target. You can have only one search session Find in Exchange Target
window open at one time.

Note:Only accessible mailboxes and public folders of the Microsoft Exchange Server can be
searched.

Tip: CAS and PST files are not searchable in the target pane but are searchable in the source
pane.

To search a Microsoft Exchange Server target

1. Do one of the following to display the Find in Exchange Target window:
l Right-click the valid object in the target pane and click Find.
l On the Tools menu, click Find.

l On the toolbar, click the Find icon .
l Press F3.

2. Conduct search as described in "Searching Sources" on page 63.

Tip: Microsoft Exchange Server target search results can have an Integrity Check performed
either by right-clicking the message or click Integrity Check in the Tools menu.

68



Chapter 3: Finding Messages

Managing Message Items
Once you have performed a target search, several functions are available on the search results
including cut, move, export, copy, and delete.

Moving Message Items
Moving message items from the search results to another folder within the target directory
removes the message items from the original location. You can move message items by using
the Move To Folder function, or by dragging and dropping to the destination folder.

Move to Folder

SPGRE presents you with a Move To Folder option and a corresponding Move Items destination
selection window.

Note:Message items cannot be moved to a Content Analysis Store (CAS).

To move to folder using Move To Folder

1. Do one of the following to display the Move Items window:
l Right-click the message item(s) in the search results and click Move To Folder.
l On the Edit menu, click Move To Folder.

2. Select a folder as the destination and click OK. The Copy Progress window appears.
3. Select Print to print the progress report, Save to save the progress report to your hard drive,

or Close to close the window.

Moving Message Item using Drag and Drop

Drag and drop from a Find in Target search result list has a "Move" option. This option behaves in
the same manner as the Move to Folder function or cut and paste.

To move to folder using drag and drop

1. Right-click the message item in the search results and drag to a mailbox in the target
pane.

2. At the destination mailbox, a shortcut menu appears with the options of Paste, Move,
Paste Special, or Cancel. Select one and the Copy Progress window appears.

3. Click Print to print the progress report, Save to save the progress report to your hard drive,
or Close to close the window.

Copying Message Items
You can copy message items to Microsoft Exchange Server and PST file targets. Only valid
targets are displayed in the Copy Items window.

Copy to Folder

SPGRE presents you with a Copy To Folder option which copies the item and keeps it in its original
location to be pasted in a designated location.
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To copy to folder

1. On the Edit menu, click Copy To Folder. The Copy Items window appears.
2. Select a folder as the destination and click OK. The message item is now copied and

pasted to the designated location.
3. In the Copy Progress window, click Print to print the progress report, Save to save the

progress report to your hard drive, or Close to close the window.

Cutting and Deleting Message Items
The target search results has two new actions, cutting message items and deleting message
items, which are only available in the target search results window.

Cutting Message Items

Cutting a message item moves the item from the original location to a given target.

Deleting Message Items

Deleting a message item in the search results works in a similar manner as deleting message
items from the main target list. When you delete message items from the search results list, they
are also deleted from the main target list if the same message item is currently displayed.

Note: You cannot delete message items from the main target list if the Find in Exchange Target
dialog is open.

Saving and Using Search Profiles
SPGRE allows you to save search criteria to a text file for the purpose of using the search criteria
in future searches. There are two menu commands that allow you to perform these functions:
"Save Criteria" and "Use Previous Criteria." In addition, if you want to modify the search criteria in
a search profile, you can edit the text file with a text editor.

When creating a search profile, you can save the following search criteria. The "Search For,"
"Exclude Words," "Sent from," and "Sent to" fields have a maximum of 4,095 characters.

n Search for words
n Exclude words
n Search in
n Sent from
n Sent to
n Created Dated after
n Created Dated before

Note: The saved criteria of a content analysis store profile folder can be used for a search.
Conversely, the saved criteria for a search can be used to create a content analysis store profile
folder. For more information on content analysis stores, see "Content Analysis Store" on page 121.
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To create a search profile

1. Open the Find in Source window, and enter search criteria.
2. On the File menu in the Find in Source window, click Save Criteria.
3. In the Save As window, specify a name and location for the search profile text file.
4. Click Save.

To edit a search profile

1. Locate and open the search profile that you want to edit.
2. Modify the search criteria as desired and save the text file.

To use a search profile when performing a search

1. Open the Find in Source window.
2. On the File menu in the Find in Source window, click Use Previous Criteria.
3. In the Open window, locate and open the search profile that you want to use for your

search.
4. Click Open. The Find in Source window is populated with the search criteria specified in

the search profile.

Using Multiple Search Windows
SPGRE allows you to open multiple instances of the Find in Source window to search any
combination of information stores at the same time. There is no limit other than system resources
for the number of concurrent searches you can initiate.

When searching on a live Microsoft Exchange Server target, you are able to have only one
instance of a search session Find in Exchange target window at one time.

Note: If you are using multiple instances of the Find in Source window to search within the same
mailbox, youmay notice a slowdown in performance.

Searching Within Attachments
In both the Find in Source and Find in Exchange Target windows, you can search the text of email
attachments. The Searching within Attachments feature supports Unicode text and is available
for EDB, PST, CAS sources, and Microsoft Exchange Server targets. SPGRE supports Microsoft
Office documents and many other popular file types.

Note about the licensing agent: The "PC Agent for Advanced Searching" must be enabled in
order to search attachments. For more information, see Enabling the Licensed Agents" in the
Readme file.
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Figure 3-5: Select the Attachment Text option to include in your search

To search within attachments

1. In the Find in Source or Find in Exchange Target window, select the Attachment Text check
box.

2. Specify other desired search criteria. For more information, see "Searching Sources".
3. Click Find Now. If SPGRE matches a keyword or phrase in the text of the attachment, it will

return a "Hit" just as it would if it found a keyword or phrase in the body or subject of a
message item.

Exceptions When Searching Within Attachments
SPGRE does not search for the following items:

n Archive files (for example, .zip, .rar)
n Binary files (for example, .dll, .exe, .jpg)
n Metadata associated with files (for example, author and company information in an .xls

file)

Other SPGRE Features Available Through the
Find Window
In addition to the search features described in the previous sections, there are several SPGRE
features available through the Find window.

72



Chapter 3: Finding Messages

Opening and Saving Attachments in the Find Window
To open an attachment's file type in the Find window, you must have an application installed on
your computer that can perform this function. If no associated program is available for the
attachment file type, SPGRE presents a message window saying the attachment cannot be
viewed.

For instructions on opening and saving attachments, see "Opening Attachments " on page 14
and "Saving Attachments" on page 15.

Exporting Message Items from the Find Window
The Export feature allows you to copy individual message items from the Find window to a local
or network drive destination. You can choose to save exported message items as plain text files
(.txt) or Microsoft Office Outlook® files (.msg).

To export message items from the Find window

1. In the Find in Source or Find in Exchange Target window, perform a search.
2. In the Results area, select the message items you want to export.
3. On the Tools menu in the Find in Source or Find in Exchange Target window, click Export.
4. In the Export window, specify options and click Export. For more information on the export

options, see "Exporting Messages" on page 76.

Restoring Message Items from the Find Window
The results of conducting a search appear in the message item list in the Find window. You can
restore the message items in this list by dragging them or copying and pasting them into the
target folder. If you want to maintain the directory structure of restored individual message
items, use the Paste Special command.

You can also restore message items by browsing in the main window and dragging and dropping
or copying and pasting from the main window to the target. You do not need to search to
restore message items. For more information, see "Restoring Microsoft Exchange Server Data" on
page 85.

Performing an Integrity Check on Message Items in the Find
in Source Window
The Find in Source window allows you to perform an integrity check on one or more message
items in the Results area. During the integrity check, SPGRE verifies that it can read all of the
properties of the message items.

Note:Only accessible mailboxes can have an Integrity Check performed.
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To perform an integrity check on message items in the Find in Source window

1. In the Find in Source window, perform a search.
2. In the Results area, select the message items for which you want to perform an integrity

check.
3. On the Tools menu in the Find in Source window, click Integrity Check. The Integrity Check

window appears.

Search Results Report
You can save a text-based report of the search results to your local drive without having to copy
or export any of the search results. The search results report is saved into a file that includes the
search criteria, date/time the search was started, and a report of message items that matches
the criteria.

Save Report
You can save the search results report once a search has been performed and either
completed or stopped.

The Save Report button creates two text-based reports. One report contains a search session
summary (Summary Report) and the other report contains search session message item results
(Message Report).

Summary Report
The information included in the Summary report is the search session details and the user-defined
search criteria for the search.

Message Report
The information included in the Message report is based on the column headings in the search
results, message type, attachments, From and To, etc.

To save the report

1. After conducting the search, click Save Report. The Browse For Folderwindow appears.
2. Select the destination for the report and click OK. The search results reports creates both a

Message Report and a Summary Report, and are saved on your hard drive in a .txt format.

Figure 3-6: Summary andMessages Reports

74



Chapter 3: Finding Messages

The files are named using the date of the search and a suffix indicating the type of report.
For example, if you run a search on 5/8/2007, the report names are:
SearchResults_20070508_Summary.txt for the summary report, or
SearchResults_20070508_Messages.txt for the message report.

For cases where you choose to create more than one set of reports on the same date, files
are named using an incremental numbering convention starting with "1." If you run a
second search on 5/8/2007, the report names are:
SearchResults_20070508(1)_Summary.txt for the summary report, or
SearchResults_20070508(1)_Messages.txt for the message report.

3. Clicking Cancel during the report generation progress terminates the process and any
reports created for this Save Report action are deleted from the report destination.

Using the Report
The text summary or message report is tab delimited and can be imported into a spreadsheet if
desired. Simply drag the .txt file from its location into a blank spreadsheet. The source # in the
search results is replaced with the full path to its location in the report.
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Overview
You can export mail from an EDB, PST, or CAS source file to a local or network drive destination.
Exported messages can be saved as Microsoft® Office Outlook® files (.msg) or plain text files
(.txt). This can assist you in copying old email backups into an alternate or non-email system. You
can export at all levels: an EDB file, a PST file, a CAS file, a CAS profile folder, a mailbox, a folder,
and individual messages. EDB files can be exported to PSTs.

General Information about Exporting Messages
n The file name for an exported message is its subject. A duplicate subject name will create

a file with the same name but with an (x) appended to the filename: x = 1 for the first
duplicate, x = 2 for the next duplicate, and so on. If the subject contains illegal file name
characters, the offending characters will be replaced with an underscore.

n Associated messages and folder properties will not be exported.
n When exporting individual messages, you have the option to keep the folder/mailbox

hierarchy, similar to the paste special feature. When exporting a mailbox or folder, you
have the option to also export the subfolders.

n Messages in the Microsoft Exchange Server 2010 Recoverable Items folders can be
exported if the Show Recoverable Items (Microsoft Exchange Server 2010) preference is
enabled.

n When exporting the Recoverable Items folder, it is renamed to distinguish the copied
version from the actual version. The folder is renamed using the localized short date in
parenthesis and appended to the folder name. Example: "Recoverable Items (10/22/2009)
"

n If you use the "Mailbox Criteria (optional)" box on the Select Source Files dialog box or the
Source Path Selection page of the DataWizard, only EDB mailboxes containing your entry
(or entries) are displayed on the Source Pane. Any mailboxes which do not match the
entered string(s) will not appear in the Source Pane and will not be included in any
subsequent tasks (such as searching, copying, and exporting of the entire database). For
more information, see "MailboxCriteria" on page 34.

About Message (.msg), Text (.txt), and PST
Export
The file type for an exported message can be either Microsoft Office Outlook (.msg) or plain text
(.txt). EDB files can be exported to a PST.

Message (.msg) export
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A .msg file (OLE compound document) can be imported directly into Microsoft Office Outlook.
This file type encapsulates the entire message including attachments.

Text (.txt) export

A .txt file is created with the following information. Note that neither message attachments nor
message properties are exported.

PST export

The Export to PST option allows you to generate PST files for one or all users'; mailboxes from an
off-line EDB file. ShadowProtect Granular Recovery for Exchange (SPGRE) generates a single PST
file for each user's mailbox. See "Exporting to PST" on page 81 for more information.

Exporting Messages
The following instructions show you how to export an EDB file, a PST file, a CAS file, a CAS profile
folder, mailboxes, folders, and messages from the source pane in the SPGRE main window. They
also show you how to export messages from the Find in Source or Find in Exchange Target
window.

Note:Only accessible mailbox items can be exported. If you are exporting a CAS file, only
accessible mailboxes are included in the export.

To export an entire EDB file

1. In the source pane, select the EDB file.
2. Do one of the following:

l On the Tools menu, click Export.

l On the toolbar, click the Export icon .
l Right-click the EDB file, and on the shortcut menu, click Export. The Export EDB window

appears.

Figure 4-1: MSG or TXT format can be selected for Export

3. In the Format box, select MSG or TXT.
4. In the Export To box, specify the location for the exported EDB file.
5. Click Export.
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6. In the Export Progress window, verify the EDB file was successfully exported, and click
Close.

To export a PST file, a mailbox, or a folder

1. In the source pane, select a PST file, a mailbox or a folder (for example, Inbox).
2. Do one of the following:

l On the Tools menu, click Export.

l On the toolbar, click the Export icon .
l Right-click the mailbox or folder, and on the shortcut menu, click Export. The Export

Mailboxor Export Folderwindow appears.

Figure 4-2: Export Mailboxwindow

Figure 4-3: Export Folder window

3. In the Format box, select MSG or TXT.
4. In the Export To box, specify the location for the exported mailbox or folder.
5. Select the Export Subfolders check box if you want to export all of the subfolders for the

selected mailbox or folder.
6. Click Export.
7. In the Export Progress window, verify the mailbox or folder was successfully exported, and

click Close. The mailbox or folder appears in the specified location. In the illustration
below, the exported folder is the Inbox.
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Figure 4-4: The exported Inbox appears in the specified location

To export individual messages

1. In the source pane, select one or more messages from the message list.
2. Do one of the following:

l On the Tools menu, click Export.

l On the toolbar, click the Export icon .
l Right-click the selection, and on the shortcut menu, click Export. The Export Messages

dialog box appears.

Figure 4-5: MSG or TXT format can be exported

3. In the Format box, select MSG or TXT.
4. In the Export To box, specify the location for the exported messages.
5. Select the Maintain Message Path check box if you want to maintain the directory

structure of the exported messages.
6. Click Export.
7. In the Export Progress window, verify your messages were successfully exported, and click

Close. The messages appear in the specified location. In the illustration below, the
exported messages come from the "User 1" mailbox.
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Figure 4-6: Messages appear in specified location

To export individual messages from the Find window

1. In the Find in Source or Find in Exchange Target window, select one or more messages from
the message list.

2. Right-click the selection, and on the shortcut menu, click Export.
3. Perform steps 3-7 in the preceding section.

To export individual messages from the source content analysis store profile folders

1. In the source message pane, select a profile folder, then select one or more messages
from the message list.

2. Do one of the following:
l On the Tools menu, click Export.

l On the toolbar, click the Export icon .
l Right-click the selection, and on the shortcut menu, click Export. The Export Messages

window appears.

Figure 4-7: MSG or TXT format can be exported

3. In the Format box, select MSG or TXT.
4. In the Export To box, specify the location for the exported messages.
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5. Select the Maintain Message Path check box if you want to maintain the directory
structure of the exported messages.

6. Click Export.
7. In the Export Progress window, verify your messages were successfully exported, and click

Close.

Exporting to PST
The Export to PST option allows you to generate PST files for one or all users' mailboxes from an off-
line EDB file. SPGRE generates a single PST file for each user's mailbox. If Microsoft Office Outlook
2003 or greater is installed on your computer, you have the option of creating either Microsoft
Office Outlook 97-2002 style PST files or Microsoft Office Outlook 2003 style PST files.

This feature is available with the following source selections in the source pane:

n EDB Source(s)-Export all mailboxes to PST files
n One mailboxwithin an EDB Source-Export EDB mailbox to PST files

Note: EDB sources that are a result of a search cannot be exported to PST.

Note: Before exporting to PST, ensure that you have sufficient disk space available at the
destination of the PST export.

To export to PST

1. Highlight the item to export.
2. Do one of the following:

l Right-click and click Export

l On the toolbar, click the Export icon .
l On the Tools menu, click Export.

3. Select PST in the Format drop-down list.
4. Select the destination in Export To field.
5. Click Export. The Outlook Version window appears.

Note: If your system hasMicrosoft Office Outlook 2003 or later installed, then SPGRE has the
capability to create either Microsoft Office Outlook 97-2002 or Microsoft Office Outlook
2003 style PST files. If this is the case, you are presentedwith a window prompting you to
select which style of PST you want to create.
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Figure 4-8: Select Microsoft Office Outlook Version

6. Select the appropriate version of Microsoft Office Outlook and click OK. The Export
Progress window is displayed.

7. After the export has completed, click Print to send to printer, Save to save a .txt report of
the export to your local drive, or Close to close the window.

To use exported PST

1. Navigate to the location where the PST was created.
2. Drag and drop the PST into SPGRE in either the source or the target pane. The Select

Source Files window appears.
3. Click OK. The PST now appears in the target or source directory.

Output
Note: By default, the limit for a .pst file in Microsoft Office Outlook 2003 and in Microsoft Office
Outlook 2007 is configured to be 20GB. As a result, exporting Microsoft Office Outlook 2003 or
Microsoft Office Outlook 2007 .pst files larger than 20GB is not supported.

The PST files generated are named according to the mailbox name and placed in a folder
named after the EDB. For example, if you wanted to export all the mailboxes from Priv1.edb
(John Doe, Jane Doe, and User5), and you selected C:\PST as the "Export To:" folder, the
exported folders and PST files would look like:

C:

PST

Priv1.edb
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John Doe.pst

Jane Doe.pst

User5.pst

Already Existing Files
If any of the exported PST files already exist, SPGRE adds a number in parenthesis to the file name
so that it does not conflict with an existing file. For example, if John Doe.pst already exists, then
the exported PST for John Doe would be named "John Doe(1).pst." If John Doe(1).pst also exists,
then the exported PST would be named "John Doe(2).pst."

Note: There is a 2GB limit for Microsoft Office Outlook 97-2002 style PSTs. See "Limits for PST and
Folder Targets" on page 86 for more information.

About the Export Progress Window
Each time you attempt to export messages, the Export Progress window appears. This window
displays the following information:

n Source and target
n Export start time
n Number of folders to export
n Number of messages to export
n Warnings or errors encountered during the export process. If an error occurs on a message,

the message subject and source path along with an error message will be displayed. If the
message does not have a subject, the date (created) and message sender will be
displayed instead.

n Total folders and messages successfully exported
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Figure 4-9: The export progress is shown

Note:

n If an error occurs that SPGRE can recover from, such as a corruption that prevents it from
getting amessage property, SPGRE will log an error, stop processing that message, and
continue.

n If an error occurs from which SPGRE cannot recover, such as amajor corruption error,
SPGRE will log an error to the Export Progress window and stop exporting.

Saving and Printing the Report
The contents of the export report can be saved by clicking Save. This brings up a Save File dialog
box allowing you to select the location and name of the file. The default name of the report is
"ExportProgress.txt."

The export report can also be printed by clicking Print.
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Overview
The first part of this chapter provides you with a quick look at restoring your Microsoft Exchange
Server database, so you can begin to use the Microsoft Exchange Server application of
ShadowProtect Granular Recovery for Exchange (SPGRE) immediately. The second part of this
chapter provides examples of restoring messages, folders, mailboxes, and even an entire EDB file
to the desired destination.

Note: The concepts in this chapter apply to EDB, PST, andCAS files (unless otherwise noted),
even though all of the examples of sources are EDB files.

Note: If you use the "MailboxCriteria (optional)" box on the Select Source Files dialog box or the
Source Path Selection page of the DataWizard, only EDB mailboxes containing your entry (or
entries) are displayed on the Source Pane. Anymailboxes which do not match the entered string
(s) will not appear in the Source Pane andwill not be included in any subsequent tasks (such as
searching, copying, and exporting of the entire database). For more information, see "Mailbox
Criteria" on page 34.

Quick Look at Restoring Your Microsoft
Exchange Server Data
Restoring data from a source EDB, PST, or CAS file to a target destination is a simple process. Just
drag and drop or use the Copy and Paste/Paste Special commands.

n "Restoring Your Microsoft Exchange Server Data in Three Easy Steps" on page 85
n "Limits for PST and Folder Targets" on page 86
n "About Restoring Messages to a Microsoft Exchange Server" on page 87
n "About the Copy Progress Window " on page 87
n "Creating, Renaming, and Deleting Folders in the Target Pane" on page 88
n "Copying and Pasting or Dragging and Dropping" on page 89

Restoring Your Microsoft Exchange Server Data in Three
Easy Steps
If you copy an EDB file, a PST file, a mailbox, or a folder from the source pane and paste it to any
target destination, SPGRE will preserve the directory structure of all restored messages. When
restoring individual messages, you must use the Paste Special command to preserve their
directory structure.
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To restore individual messages with copy-paste

1. In the source pane or Find in Source window, copy messages from the message list.
2. In the target pane, paste the messages into a folder.
3. In the Copy Progress window, verify that your messages were successfully copied, and

click Close.

To restore individual messages with copy-paste special

1. In the source pane or Find in Source window, copy messages from the message list.
2. In the target pane, use Paste Special to paste the messages into a folder, mailbox, PST

root, or Microsoft Exchange Server root.
3. In the Copy Progress window, verify that your messages were successfully copied, and

click Close.

Tip: Use the Paste Special command to retain the directory structure of messages copied
from the Find in Source or Find in Exchange Target window, because messages in this
window often come from several source locations.

To restore a folder, a mailbox, an EDB file, a CAS file, or a PST file

1. In the source pane, copy a folder, a mailbox, an EDB file, a CAS file, or a PST file.
2. In the target pane, paste the copied item into a folder, mailbox, PST root, or Microsoft

Exchange Server root.
3. In the Copy Progress window, verify that your messages were successfully copied, and

click Close.
Note: You cannot open the same PST as a source and target. In addition, you cannot
restore messages from a PST file to aMicrosoft Exchange Server root node.

To restore data even faster, use drag-and-drop

n Example: To restore an entire EDB file, drag it to the target Microsoft Exchange Server root.

Limits for PST and Folder Targets
When restoring Microsoft Exchange Server Data to a target PST or folder, Microsoft Office
Outlook 97-2002 style PSTs have the following limits:

2GB PST Limit

When a target PST file reaches 1.8 GB, SPGRE creates a new PST for the additional messages. The
new PST file has the same name as the original target PST file, plus an appended number in
parentheses: Personal Folders (1), Personal Folders (2), and so on. SPGRE creates the folder path
in the new PST and continues to restore Microsoft Exchange Server data where it left off.

Note: The 1.8GB limit applies only to PST files created byMicrosoft office Outlook 2002 and
earlier. This limit does not apply to the new type of PST files created byMicrosoft Office Outlook
2003 or 2007.

16,383Messages Per Folder (for example, Inbox) Limit
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When a target folder (for example, Inbox) reaches 16,383 messages, SPGRE creates a new PST
folder for the additional messages. The new folder has the same name as the original target
folder plus an appended number in parentheses: Inbox (1), Inbox (2), and so on. SPGRE creates
the folder path in the new folder and continues to restore Microsoft Exchange Server data where
it left off.

Note: If you have upgraded the PST file to a large table format, the PST can hold 64,000messages
per folder. However, when a target folder (for example, Inbox) reaches 16,383messages, SPGRE
still creates a new PST folder for the additional messages.

To turn off the preference setting for the PST messages per folder limit
If you do not want SPGRE to create new folders when the number of messages reaches 16,383,
do the following:

1. On the Edit menu, click Preferences.
2. In the Preferences window, click the Options tab, and then clear the Create new PST

folders when PST message/folder limits are reached check box.

Note: If you turn off the preference, all messages above the messages per folder limit will fail to
copy correctly, and the PST file may become corrupt.

About Restoring Messages to a Microsoft Exchange Server
You must have sufficient access rights to all of the Microsoft Exchange Server mailboxes you are
trying to restore messages to. Keep in mind that you can connect to only one mailbox at a time.

Restoring Messages to Microsoft Exchange Server 2000/2003/2007/2010

In Microsoft Exchange Server 2000/2003/2007/2010, the permission that controls whether or not
any mailbox can be copied to is Full Mailbox Access. You must have Full Mailbox Access set to
"Allow" in order to copy to a mailbox other than the one you logged in under.

About the Copy Progress Window
Each time you attempt to restore messages to the target pane, the Copy Progress window
appears. This window displays the following information about the copy operation:

n Time of copy operation
n Number of messages, associated messages, and folders
n Errors, if any
n Mailboxes that SPGRE connected to or failed to connect to when copying to a Microsoft

Exchange Server
n Copy results
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Important: Viewing the copy results in Copy Progress window is especially important when
attempting to restore multiple items to a Microsoft Exchange Server root node. That is because
SPGRE restores one mailbox at a time; therefore, the only way you will know if all of the
mailboxes were successfully copied to the Microsoft Exchange Server will be to look at the copy
results listed in this window.

If you do not have full access rights to the mailboxes you are trying to restore messages to, SPGRE
will be unable to connect to the mailboxes. For more information, see "About Restoring
Messages to a Microsoft Exchange Server" on page 87.

Creating, Renaming, and Deleting Folders in the Target Pane
The target pane has folders in which you can place your restored messages. However, you may
want to create new folders for your messages. You can also rename or delete any folder in the
target pane.

To create a new folder in the target pane

1. In the target pane, select a folder, a PST root node, or a Microsoft Exchange Server
mailbox.

2. Do one of the following:
l On the Edit menu, click New Folder.
l Right-click and on the shortcut menu, click New Folder.
l PressCtrl+N.

3. In the Create New Mail Folderwindow, name the folder and click OK. A subfolder is
created in the target folder.

To rename a folder in the target pane

1. In the target pane, select a folder.
2. Do one of the following:

l On the Edit menu, click Rename.
l Right-click and on the shortcut menu, click Rename.
l PressCtrl+R.

3. Type a new name for the folder.

Note: You can also rename a PST root.

To delete a folder in the target pane

1. In the target pane, select a folder.
2. Do one of the following:

l On the Edit menu, click Delete.
l Press the Delete key.
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Copying and Pasting or Dragging and Dropping
In SPGRE, you can restore data to the target pane by using Copy-Paste, Copy-Paste Special, or
Drag-and-Drop.

Note: If you copy the Recoverable Items folder, it is renamed to distinguish the copied version
from the actual version. The folder is renamed using the localized short date in parenthesis and
appended to the folder name. Example: "Recoverable Items (10/22/2009)"

To copy an item in the source pane or Find window

1. In the source pane or Find in Source window, select messages, a folder, a mailbox, or the
entire EDB file.

Note: In the Find in Source window, you can only select messages.

2. Do one of the following:
l On the Edit menu, click Copy.
l Right-click the selected item(s), and on the shortcut menu, click Copy.

l Click the Copy Mail Item icon on the toolbar.
l PressCtrl+C.

To paste an item in the target pane

1. In the target pane, select a folder, a mailbox, the PST root node, or the Microsoft
Exchange Server root node.

2. Do one of the following:
l On the Edit menu, click Paste.
l Right-click the selected item, and on the shortcut menu, click Paste or Paste Special.

For more information on using the Paste Special command, see "Restoring Messages
with Copy-Paste" on page 90.

l Click the Paste icon on the toolbar.
l PressCtrl+V (Paste) or Ctrl+Y (Paste Special).

To use drag-and-drop

n Drag an item from the source pane into a folder in the target pane. Dragging and
dropping achieves the same results as copying and pasting.

To use drag-and-drop when right-clicking a source item

1. In the source pane, select one or more messages.
2. Right-click the selected messages and drag them to a folder in the target pane.
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3. When you let go of the mouse, a shortcut menu appears. On the shortcut menu, click
Paste or Paste Special. For more information on using the Paste Special command, see
"Restoring Messages with Paste Special" on page 91.

Examples of Restoring Your Microsoft Exchange
Server Data
This section provides examples of restoring messages, folders, mailboxes, and even an entire EDB
file to the desired destination. In each case, it provides guidelines for restoring messages.

Note: The concepts in this chapter apply to both EDB and PST files (unless otherwise noted), even
though all of the following examples are EDB files.

Restoring Messages with Copy-Paste
The following instructions show you how to restore individual messages to a folder in a target PST
file or Microsoft Exchange Server by using Copy-Paste. Keep in mind that using Drag-and-Drop
achieves the same results.

Guidelines for Restoring Messages

n You can copy messages from the message list in the source pane or the Find in Source
window.

n You can use Drag-and-Drop or Copy-Paste to restore individual messages to a folder in the
target pane.

n You cannot use Drag-and-Drop or Copy-Paste to restore individual messages to a PST root
node, a Microsoft Exchange Server root node, or a Microsoft Exchange Server mailbox.
However, you can use Paste Special to restore individual messages to these locations.

n Using Drag-and-Drop or Copy-Paste to restore individual messages does not preserve the
directory structure of the restored messages. If you want to preserve the directory structure
of restored individual messages, use Paste Special.

n You cannot copy-paste inaccessible mailboxes.

Tip: For information on Paste Special, see "Restoring Messages with Paste Special" on
page 91.

To restore messages with copy-paste

1. In the source pane or Find in Source window, copy messages from the message list.
2. In the target pane, paste the messages into a folder (for example, Inbox) in the target PST

file or Microsoft Exchange Server.
3. In the Copy Progress window, verify that your messages were successfully copied. You can

also print or save the copy report by doing one of the following.

90



Chapter 5: Restoring Microsoft Exchange Server Data

l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the main window.

Results of Restoring Messages with Copy-Paste

All unduplicated messages appear in the target folder.

Restoring Messages with Paste Special
You can use the Paste Special command to preserve the directory structure of restored
individual messages. The Paste Special command is especially useful when restoring messages
from the message list in the Find window, since these messages often come from several source
locations.

Guidelines for Restoring Messages with Paste Special

n You can use the Paste Special command to restore individual messages to any target
destination. Using the Paste Special command preserves the directory structure of the
restored messages.

n You can use the Paste Special command to restore individual messages only. You cannot
use the Paste Special command to restore an entire EDB file, a mailbox, or a folder.

n You cannot use Paste Special to restore messages to a public folder.
n If the target is a PST root node or folder, SPGRE creates a folder to represent each mailbox.

Each mailbox is a subfolder of the folder the user selected for the Paste Special operation.
n If the target is a Microsoft Exchange Servermailbox or folder, SPGRE copies all messages to

the target. Each mailbox is a subfolder of the folder the user selected for the Paste Special
operation.

n If the target is a Microsoft Exchange Server root node, the Paste Special code attempts to
connect to each mailbox one at a time and copies each message to its corresponding
mailbox and folder. If the folder does not exist, it will be created. If the mailbox does not
exist, SPGRE logs an error in the copy results, skips the entire mailbox, and continues the
Paste Special operation.

Note: You cannot restore messages from a PST file to aMicrosoft Exchange Server root
node.

To restore messages to a PST root or folder with Paste Special
If the target is a PST root node or folder, SPGRE creates a folder to represent each mailbox. Each
mailbox is a subfolder of the folder you selected for the Paste Special operation.

1. In the source pane or Find in Source window, copy messages from the message list.
2. In the target pane, use Paste Special to paste the messages into a PST root node or folder.
3. In the Copy Progress window, verify that your messages were successfully copied. You can

also print or save the copy report by doing one of the following.
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l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the main window.

Results of Restoring Messages to a PST Root Node or Folder with Paste Special

All unduplicated messages appear in the target destination, and their directory structure will be
preserved.

To restore messages to a Microsoft Exchange Server mailbox or folder with Paste Special

If the target is a Microsoft Exchange Server mailbox or folder, SPGRE copies all messages to the
target. Each mailbox is a subfolder of the folder you selected for the Paste Special operation.

1. In the source pane or Find in Source window, copy messages from the message list.
2. In the target pane, use Paste Special to paste the messages into a Microsoft Exchange

Server mailbox or folder.
3. In the Copy Progress window, review your results to make sure all the messages were

copied to the target destination. You can also print or save the copy report by doing one
of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the main window.

Results of Restoring Messages to a Microsoft Exchange Server Mailbox or Folder with Paste
Special

Each mailbox is a subfolder of the target destination, and all unduplicated messages are
restored. In addition, their directory structure is preserved.

Figure 5-1: Results of using Paste Special on a target Microsoft Exchange Server mailbox
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To restore messages to a Microsoft Exchange Server root node with Paste Special
If the target is a Microsoft Exchange Server root node, SPGRE attempts to connect to each
mailbox one at a time and copies each message to its corresponding mailbox and folder. If the
folder does not exist, it is created. If the mailbox does not exist, SPGRE logs an error in the Copy
Progress window, skips the entire mailbox, and continues the Paste Special operation.

Important: The source mailbox must exist on the target Microsoft Exchange Server, and you must
have full mailbox access rights to all of the Microsoft Exchange Server mailboxes to which you
are trying to restore messages. For more information on access rights, see "About Restoring
Messages to a Microsoft Exchange Server" on page 87.

1. Select one or more messages from the message list in the Find in Source window or the
source pane.

2. In the source pane or Find in Source window, copy messages from the message list.
3. In the target panes use Paste Special to paste the messages into a Microsoft Exchange

Server root node.
4. In the Copy Progress window, verify your results to make sure that your messages from all

mailboxes were copied to the target destination. You can also print or save the copy
report by doing one of the following:

l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

5. In the Copy Progress window, click Close to return to the SPGRE main window.

Results of Restoring Messages to a Microsoft Exchange Server Root Node with Paste Special

All unduplicated messages are restored in each mailbox that SPGRE can connect to, and the
directory structure of the messages is preserved.

When attempting to restore multiple mailboxes to a Microsoft Exchange Server root node, you
must look at the Copy Progress window to verify that your messages from all mailboxes were
successfully copied to the Microsoft Exchange Server. That is because SPGRE displays only one
mailbox at a time in the target pane.

Restoring a Folder
The following instructions show you how to restore a folder to any target destination by using
Copy-Paste. Keep in mind that using Drag-and-Drop achieves the same results.

Guidelines for Restoring a Folder

n You can use Drag-and-Drop or Copy-Paste to restore a folder to a target PST root node or
folder, or to a Microsoft Exchange Server mailbox or folder. If the folder does not exist in the
target destination, it is created.

n You cannot restore a folder to a Microsoft Exchange Server root node.
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n You cannot restore a private folder to a public folder. But you can restore messages from a
private folder to a public folder.

n You cannot use the Paste Special command to restore a folder. You can use the Paste
Special command to restore individual messages only.

n If you copy the Recoverable Items folder, it is renamed to distinguish the copied version
from the actual version. The folder is renamed using the localized short date in parenthesis
and appended to the folder name. Example: "Recoverable Items (10/22/2009)"

To restore a folder

1. In the source pane, copy a folder (for example, Inbox).
2. In the target pane, paste the folder into a folder, mailbox, or PST root node.
3. In the Copy Progress window, verify your results to make sure that your messages from all

mailboxes were copied to the target destination. You can also print or save the copy
report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the SPGREmain window.

Results of Restoring a Folder

All unduplicated messages in the folder are restored and their directory structure is preserved. If
the folder does not exist in the target destination, it is created.

Note: No folder is created because the copied folder (Inbox) already exists in the target
Microsoft Exchange Server mailbox.

Restoring a Mailbox
The following instructions show you how to restore a mailbox to any target destination by using
Copy-Paste. Keep in mind that using Drag-and-Drop achieves the same results.

Guidelines for Restoring a Mailbox

n You can use Drag-and-Drop or Copy-Paste to restore a mailbox to a target PST root node
or folder, or to a Microsoft Exchange Server root node, mailbox, or folder.

n If you restore a mailbox to a target PST root node: Messages from folders in the source PST
are restored to corresponding folders in the target PST (for example, messages from the
source Inbox are restored to the target Inbox). If a corresponding folder does not exist in
the target destination, it is created.

n If you restore a mailbox to a to a target PST folder, or to a Microsoft Exchange Server,
mailbox, or folder: If the mailbox does not exist in the target destination, a folder with its
name is created.
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Important: If you want to restore a mailbox to a target Microsoft Exchange Server root
node, the source mailbox must exist on the target Microsoft Exchange Server, and you
must have full mailbox access rights to all of the Microsoft Exchange Server mailboxes you
are trying to restore messages to. For more information on access rights, see "About
Restoring Messages to a Microsoft Exchange Server" on page 87.

n You cannot restore a mailbox to a public folder. But you can restore messages from a
mailbox to a public folder.

n You cannot use the Paste Special command to restore a mailbox. You can use the Paste
Special command to restore individual messages only.

To restore a mailbox

1. In the source pane, copy a mailbox (for example, User 1).
2. In the target pane, paste the mailbox into a folder, mailbox, PST root node, or Microsoft

Exchange Server root node.
3. In the Copy Progress window, verify your results to make sure that your messages from all

mailboxes were copied to the target destination. You can also print or save the copy
report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the SPGRE main window.

Results of restoring a mailbox

All unduplicated messages in a mailbox are restored and their directory structure is preserved.

If the mailbox does not exist in the target destination, a folder with its name is created. However,
if you restore a mailbox to a target PST root node, a mailbox is not created. Instead, messages
from folders in the source PST are restored to corresponding folders in the target PST.

Restoring an EDB File
The following instructions show you how to restore an entire EDB file to any target destination with
Copy-Paste. Keep in mind that using Drag-and-Drop achieves the same results.

Guidelines for Restoring an EDB File

n It is recommended that you restore an EDB file to a target Microsoft Exchange Server root
node.

n You can use Drag-and-Drop or Copy-Paste to restore an entire EDB file. You cannot use
the Paste Special command to restore an EDB file. You can use the Paste Special
command to restore individual messages only.
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Important: If you restore an EDB file to a target Microsoft Exchange Server root node, the
source mailbox must exist on the target Microsoft Exchange Server, and you must have full
mailbox access rights to all of the Microsoft Exchange Server mailboxes to which you are
trying to restore messages. For more information on access rights, see "About Restoring
Messages to a Microsoft Exchange Server" on page 87.

To restore an EDB file

1. In the source pane, select the EDB file.
2. On the Edit menu, click Copy.
3. In the target pane, select the Microsoft Exchange Server root node.
4. On the Edit menu, click Paste.
5. In the Copy Progress window, review your results to make sure all the messages were

copied to the target destination. You can also print or save the copy report by doing one
of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

6. In the Copy Progress window, click Close to return to the SPGRE main window.

Results of restoring an EDB file

SPGRE attempts to connect to each mailbox in the target pane one at a time and copies each
message to its corresponding mailbox and folder. If the folder does not exist, it will be created. If
the mailbox does not exist, SPGRE an error in the Copy Progress window, skips the entire mailbox,
and continues the operation.

Restoring to Public Folders
The following instructions show you how to restore messages or public folders to a public folder
target. An option to open public folders is available upon connection to a Microsoft Exchange
Server.

Important: SPGRE opens public folders and your mailbox when you connect to a Microsoft
Exchange Server target. You will see those folders that you have permission to see.

Guidelines for Restoring to Public Folders

n You can restore folders from a pub.edb database to a public folder target. All public
folder permissions are transferred to the target folders. However, folder permissions may
not transfer if the version of the source Microsoft Exchange Server is different than the
version of the target Microsoft Exchange Server.

n You can restore messages from any database source or search results to a public folder
target.

n You cannot restore a folder or mailbox from a private database to a public folder target.
But you can restore messages in a folder or mailbox to a public folder.

n You cannot use Paste Special when restoring messages to a public folder target.
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Note: The ability to restore to public folders is also available at the command line.

To restore messages to a target Public Folders

1. In the source pane or Find in Source window, copy messages from the message list.
2. In the target pane, paste the messages into the target root public folder or a folder in the

public folder.
3. In the Copy Progress window, verify that your messages were successfully copied. You can

also print or save the copy report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the SPGRE main window.

To restore a folder from a public database to a target Public Folders

1. In the source pane copy a folder from a public database.
2. In the target pane, paste the folder into the target root public folder or a folder in the

public folder.
3. In the Copy Progress window, verify that your messages were successfully copied. You can

also print or save the copy report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the SPGRE main window.

Results of Restoring to Public Folders

When you restore folders from a pub.edb database to a public folder target, the following
occurs:

n All public folder permissions are transferred to the target folders. However, folder
permissions may not transfer if the version of the source Microsoft Exchange Server is
different than the version of the target Microsoft Exchange Server.

n The Microsoft Exchange Server user doing the restore will be added to all public folder
permissions with owner rights.

n If you have IFS (also known as "M:drive") enabled on your Microsoft Exchange Server,
permissions for child folders may be merged with permissions for parent folders.

97



Chapter 6: Using the Command Line
Overview
The command line feature allows you to easily batch repetitive processes such as multiple copy
and export tasks without initiating the ShadowProtect Granular Recovery for Exchange (SPGRE)
user interface. This feature is extremely beneficial in SPGRE production environment
implementations.

Command Line Syntax
The syntax is as follows:

<< >> Required for all operations

< > Required for copy/export operations

[ ] Optional

Command Line Syntax

SPGRE [Program Options] <<Operation>> [Operation options] <<Source Store>> [Source
options] <Source Folder Path> <Target Store> <Target Folder Path>

[Program Options]

<Operation>

-Copy

-Export

-List (report information about the database)

-Integ (Integrity Check)

-h (help)

[Operation options]+

-f <format>

format:

msg - messages will be exported as .msg (.msg is the
default)

:txt - message will be exported as .txt

:pst - messages will be exported to a PST

-p <format>
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:97 - create a 97-2002 style PST for export/copy

:2003 - create a 2003 style PST for export/copy

-r

export/copy subfolders

-o <filename>

name of file to output progress information to default is CON

Note: If the file exists, SPGRE will append to the output progress file. If the file does not exist,
SPGRE will create it.

-da <mm/dd/yyyy>

Process messages dated on or after this date

-db <mm/dd/yyyy >

Process message dated on or before this date

-v <verbose>

<Source Store>

Full path of EDB file, CAS file, or PST file

[Source options]

-l <Log file path>

-t <Temp file path>

-m <Mailbox criteria>

< Source Folder Path >

full path, including mailbox to the source folder, or profile folder to be copied/exported
or $ROOT for root datastore folder

<Target Store>

ServerName;mailbox or Full path of PST

Ex. Pcpdc;jJones

Pcpdc;hJohnson

C:\archive.pst

Note: The Target Store is not needed for export.

[Target options]

-pub public folders
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<Target Folder Path>

Full path, including mailbox to the target folder to be copied/exported to or $ROOT for root
datastore folder

Note:Onlymessage containers (i.e., mailboxes, folders, entire EDB) can be selected for
copy/export. All messages contained are copied/exported. Individual messages can not be
selected from the command line.

Examples of Using the Command Line
The following examples are for pre-populate EDB file, copy, export, integrity check, and list (i.e.,
report information about the database).

Example 1: Pre-populate the EDB file, log and temp path fields of the Open Source dialog.

SPGRE c:\data.edb -l c:\edb -t c:\edb

<Operation> Explanation

Pre-populate the EDB file, log and
temp path fields of the open
source dialog

[Operation options] Explanation

Not applicable

<Source Store> Explanation

c:\data.edb Path to the EDB file

[Source options] Explanation

-l c:\edb Log file path

-t c:\edb Temporary file path

Example 2: Copy pcuser1's Inbox and all subfolders from c:\pcdata.edb to the Inbox in
c:\target.pst. c:\out1.txt will contain the copy report.

SPGRE -copy -r -o c:\out1.txt c:\pcdata.edb -l c:\edb -t c:\edb pcuser1\inbox c:\target.pst
$ROOT
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<Operation> Explanation

-copy Perform a copy operation

[Operation options] Explanation

-r Copy subfolders

-o c:\out1.txt Output report file name

<Source Store> Explanation

c:\p cdata.edb Path to the database file name

[Source options] Explanation

-t c:\edb Temporary file path

<Source Folder Path> Explanation

pcuser1\inbox Source folder to copy

<Target Store> Explanation

c:\target.pst Target data store

<Target Folder Path> Explanation

$ROOT Copy to the root folder of the
data store

Example 3: Copy pcuser1's Inbox and all subfolders from c:\pcdata.edb to user1's Inbox on
Microsoft Exchange Server pcpdc. c:\out1.txt will contain the copy report.

SPGRE -copy -r -o c:\out2.txt c:\pcdata.edb -t c:\ pcuser1\inbox pcpdc;user1 inbox

<Operation> Explanation

-copy Perform a copy operation
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[Operation options] Explanation

-r Copy subfolders

-o c:\out2.txt Output report file name

<Source Store> Explanation

c:\p cdata.edb Path to the database file name

[Source options] Explanation

-t c:\ Temporary file path

<Source Folder Path> Explanation

pcuser1\inbox Source folder to copy

<Target Store> Explanation

pcpdc;user1 Target data store (Microsoft
Exchange Server name and logon
ID)

<Target Folder Path> Explanation

inbox Copy to the inbox

Example 4: Export pcuser1's mailbox and all subfolders from pcdata.edb as text to c:\export

SPGRE -export -r -f:txt -o c:\out3.txt c:\pcdata.edb -t c:\ pcuser1 c:\export

<Operation> Explanation

-export Perform an export operation

[Operation options] Explanation

-r Export subfolders
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-f:txt Messages will be exported as .txt

-o c:\out3.txt Export report file name

<Source Store> Explanation

c:\p cdata.edb Path to the database file name

[Source options] Explanation

-t c:\ Temporary file path

<Source Folder Path> Explanation

pcuser1 Source folder to copy

<Target Store> Explanation

NA Target data store

<Target Folder Path> Explanation

c:\export Root folder of the export

Example 5: Provides information on the databases including a list of mailboxes.

Tip: When performing the -list operation, use the -o filename option in order to see the
mailboxes. Otherwise, the operation will proceed so fast that you won't be able to see the
mailboxes.

SPGRE -list -o c:\mblist.txt c:\priv1.edb

<Operation> Explanation

-list Perform a list operation

[Operation options] Explanation

-o c:\mblist.txt Output report file name
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<Source Store> Explanation

c:\priv1.edb Path to the database file name

Example 6: Provides information on the databases including a list of mailboxes using mailbox
criteria.

Tip: When performing the -list operation, use the -o filename option in order to see the
mailboxes. Otherwise, the operation will proceed so fast that you won't be able to see the
mailboxes.

SPGRE -list -o c:\mblist.txt c:\priv1.edb –m pcuser1;pcuser2

<Operation> Explanation

-list Perform a list operation

[Operation options] Explanation

-o c:\mblist.txt Output report file name

<Source Store> Explanation

c:\priv1.edb Path to the database file name

[Source options] Explanation

-m pcuser1;pcuser2 Only open pcuser1 and pcuser2
mailboxes

Example 7: Perform an integrity check on an entire EDB.

SPGRE -integ -r -o c:\output.txt c:\priv1.edb $ROOT

<Operation> Explanation

-integ Perform an integrity check on a
database

[Operation options] Explanation
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-o c:\output.txt Output report file name

<Source Store> Explanation

c:\priv1.edb Path to the database file name

<Source Folder Path> Explanation

$ROOT Root of the EDB (entire EDB)

Example 8: Copy a folder from a pub EDB to public folders (only copy messages dated after
01/01/2000)

SPGRE -copy -r -o c:\out2.txt -da 01/01/2000 c:\pub1.edb newsgroups pc2000;administrator -
pub $ROOT

<Operation> Explanation

-copy Perform a copy operation

[Operation options] Explanation

-r Copy subfolders

-o c:\out2.txt Output report file name

-da 01/01/2000 Only copy messages that were
created after this date

<Source Store> Explanation

c:\pub1.edb Path to the database file name

<Source Folder Path> Explanation

newsgroups Source folder to copy

<Target Store> Explanation
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pc2000;administrator Target data store (Microsoft
Exchange Server name and logon
ID)

<Target Options> Explanation

-pub Copy to public folders

<Target Folder Path> Explanation

$ROOT Public folders root

Important:
All paths with spaces need to be in quotes. If a PST does not exist in the target.
SPGRE will create a PST file compatible with Microsoft Office Outlook 97, 98, 2000, and XP.

Example 9: Perform an integrity check on an entire Content Analysis Store.

SPGRE -integ -r -o c:\out1.txt c:\source.cas $ROOT

<Operation> Explanation

-integ Perform an integrity check on a
database

[Operation options] Explanation

-r check subfolders

-o c:\out1.txt output report file name

<Source Store> Explanation

c:\source.cas Path to the Content Analysis Store
file name

<Source Folder Path> Explanation

$ROOT Root of the CAS (entire CAS)

Example 10: Copy Profile1 from c:\source.cas to the root in c:\target.pst.

SPGRE -copy -r -o c:\out2.txt c:\source.cas Profile1 c:\target.pst $ROOT
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<Operation> Explanation

-copy perform a copy operation

[Operation options] Explanation

-r copy subfolders

-o c:\out2.txt output report file name

<Source Store> Explanation

c:\source.cas path to the Content Analysis Store
file name

<Source Folder Path> Explanation

Profile1 source folder to copy

<Target Store> Explanation

c:\target.pst target data store

<Target Folder Path> Explanation

$ROOT copy to the root folder of the
data store

Example 11: Export Profile2 from source.cas as text to c:\export

SPGRE -export -r -f:txt -o c:\out3.txt c:\source.cas Profile2 c:\export

<Operation> Explanation

-export perform a export operation

[Operation options] Explanation

-r export subfolders
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-f:txt messages will be exported as .txt

-o c:\out3.txt export report file name

<Source Store> Explanation

c:\source.cas path to the Content Analysis Store
file name

<Source Folder Path> Explanation

Profile2 source folder to copy

<Target Store> Explanation

NA target data store

<Target Folder Path> Explanation

c:\export Root folder of the export
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Overview
This section shows you how to create reports, view the statistics in the generated reports, and
save the reports as either tab-delimited or comma-delimited text files. Any data store opened as
a source can be the source of a report.

Note: If you use the "MailboxCriteria (optional)" box on the Select Source Files dialog box or the
Source Path Selection page of the DataWizard, only EDB mailboxes containing your entry (or
entries) are displayed on the Source Pane. Anymailboxes which do not match the entered string
(s) will not appear in the Source Pane andwill not be included in any subsequent tasks (such as
searching, copying, and exporting of the entire database). For more information, see "Mailbox
Criteria" on page 34.

Creating Reports
You can generate reports on an EDB, PST, or CAS source data store in ShadowProtect Granular
Recovery for Exchange (SPGRE). The reports contain statistics about the data store such as sizes
and counts for attachments and messages, and may be generated per attachment type,
domain, mailbox, database, and date. The Mailbox and Date reports are available for Priv EDB
data sources only.

Note:Only accessible mailboxes can generate a report.

To create one or more reports

1. In the source pane, select an EDB, PST, or CAS data source.
2. On the Tools menu, click Create Reports. The Create Reports window appears.

l If you selected a Priv EDB as the source for the report, the list pane displays all
mailboxes in the EDB.

l If you selected a PST or Pub EDB as the source, the list pane displays all folders
immediately under the root of the PST or Pub EDB.
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Figure 7-1: The Create Reports dialog box

Figure 7-2: The Create Reports window for a CAS
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3. Do one of the following:
l For Priv EDB: Under Mailboxes, select the mailboxes to be included in the report(s). All

mailboxes are selected by default.
l For Pub EDB or PST: Under Folders, select the folders to be included in the report(s). All

folders are selected by default.
l For CAS: Under Profile Folders, select the folders to be included in the report(s). All

folders are selected by default.
4. Under Reports, select one or more reports that you would like to create:

l Attachment Statistics
l Domain Statistics
l Messages by Database
l Messages by Profile Folder: This report is available for CAS data sources only.
l Messages by Mailbox: This report is available for Priv EDB data sources only.
l Messages by Date: If you select this report, then specify the appropriate options for

received date range and date unit (for example, hour, day, week, month). This report
is available for Priv EDB and CAS data sources only.

5. Under Message Options, select the appropriate deleted item retention option(s). Both
options are selected by default. For PST sources, the first option is cleared. You cannot
modify the default options for PST sources.
l Include messages in deleted item retention: Select this option to include messages in

deleted item retention.

Note for Microsoft Exchange Server 2010 sources:When the Show Recoverable
Items (Microsoft Exchange Server 2010) preference is enabled (see Setting
Preferences in "Security Tab"), the messages in the Recoverable Items folder are
included in the reports for Microsoft Exchange Server 2010 sources only if the
Include messages in deleted item retention check box is selected. If the
preference setting is cleared, then the Include messages in deleted item retention
check box is unchecked and disabled for Microsoft Exchange Server 2010 reports.

l Include messages not in deleted item retention: Select this option to include
messages that are not in deleted item retention. In most cases, this option represents
most of the messages in the source data store.

6. Click Generate Reports. The Reports window appears. For more information the contents
of the reports, see "Viewing Reports".

Viewing Reports
The Reports window shows the progress of the report generation and also shows the reports
themselves. This window consists of a tabbed view of the reports, with each tab containing a
single report.
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Figure 7-3: The Reports progress window

Single Instance Storage (SIS) vs. Cumulative Counts
The Attachment Statistics and Messages by Database reports use the terms "SIS" (Single Instance
Storage) and "Cumulative" when referring to the number and size of attachments in the data
store. The term "SIS" counts attachments only once and does not include their duplicates. The
term "cumulative" refers to all of the attachments or messages, including their duplicates.

Example: An attachment of type .DOC of size 100 KB is being shared by three messages. As the
table shows, the SIS size more closely estimates how much of the EDB size is attributed to the
attachment.

The cumulative size more closely estimates how much of the EDB size is attributed to
attachments if the data store did not have SIS.

Method of Counting Attach-
ments/Messages

Total # of .DOCAttach-
ments

Total Size of .DOC
Files

SIS Count 1 100 KB

Cumulative Count 3 300 KB
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Attachment Statistics Report
The Attachment Statistics report provides statistics on all of the attachments contained in
messages in the selected source. The attachments are categorized by extension, which
appears in upper case letters (for example, .DOC, .XLS). Attachments without extensions are put
into a separate row called "No Extension."

Column Heading Description

Attachment Extension Attachment type by extension (for example, .DOC, .PPT,
.PDF).

Cumulative Number of
Attachments Found in
Messages

Cumulative number of attachments of each type found in the
processed messages.

Cumulative Size of
Attachments

Cumulative size of attachments of each type found in
messages.

Average Attachment Size Cumulative size of attachments of each type divided by the
cumulative number of attachments found in messages.

Percent of Total by Number Number of attachments of each type divided by total
attachments of all types.

Percent of Total by Size Total size of attachments of each type divided by the total
size of attachments of all types.

SIS Number of Attachments SIS number of attachments of each type. NA for PST sources.

SIS Size of Attachments SIS size of attachments of each type. NA for PST sources.

SIS Percent of Total by Size SIS size of attachments of each type divided by SIS size of
attachments of all types in attachment table. NA for PST
sources.

Domain Statistics Report
The Domain Statistics report provides statistics on messages grouped by the domain from which
the messages were sent.
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The domain is determined using the PR_SENDER_ADDRTYPE in combination with the PR_SENDER_
EMAIL_ADDRESS as follows:

l If PR_SENDER_ADDRTYPE is "EX" or "SYSTEM," then it is a Microsoft Exchange Server
message and the domain is "internal."

l If PR_SENDER_ADDRTYPE is "SMTP", then the domain is whatever follows the @ in the PR_
SENDER_EMAIL_ADDRESS property.

l If PR_SENDER_ADDRTYPE is something else, then the domain is "unknown."

Column
Heading

Description

Domain The name of the domain (for example, storagecraft.com) from which the
message was sent. All messages whose domain cannot be determined
are placed into an "unknown" domain. All Microsoft Exchange Server
messages are placed into an "internal" domain.

Number
of
Messages

Total count of messages that were received from each domain.

Total Size
of
Messages

Total size of all messages that were received from each domain.

Percent
of Total
by
Number

Number of messages from each domain divided by the total number of
messages from all domains.

Percent
of Total
by Size

Total size of messages from each domain divided by the total size of
messages from all domains.

Messages by Database Report
The Messages by Database report provides statistics on the database that contains the
processed messages. In the current version of SPGRE, reports are limited to a single EDB or PST,
which means the database report has only one row of information. For example, the database
report for Priv1.edb has one row of information listing all message statistics for Priv1.edb and its
mailboxes.
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Column Heading Description

Database (EDB, PST, or CAS) The database
name (for
example,
Priv1.edb,
Pub1.edb,
Microsoft Office
Outlook XP.pst,
User1.cas).

Cumulative Number of Messages Cumulative
number of
messages.

Cumulative Size of Messages Cumulative size of
all messages
processed.

Average Size of Messages Cumulative size of
messages divided
by cumulative
number of
messages.

Cumulative Size of Attachments Cumulative size of
attachments in all
messages
processed.

SIS Size of Attachments SIS total size of
attachments. This
column applies
only to EDB
sources. For PST
and CAS data
stores, this column
is NA.
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Figure 7-4:  The Create Reports dialog box for a Priv EDB source

Messages by Mailbox Report
The Messages by Mailbox report provides message statistics for all selected mailboxes in a Priv
EDB data store.

Note: This report is available only for a Priv EDB.

Column
Heading

Description

Mailbox Name of the mailbox: Display name (alias)

Number of
Messages

Total number of messages in the mailbox.

Total Size of
Messages

Total size of all messages in the mailbox.
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Column
Heading

Description

Average
Size of
Messages

Total size of messages divided by number of messages.

Total
Attachment
Size

Total size of attachments in all messages in this mailbox. Attachments in
messages in this mailbox that are also in messages in another mailbox are
counted in both mailboxes.

Shared
Attachment
Size

Size of attachments that are found more than once, either multiple times in
this mailbox or in this mailbox and other mailboxes. Calculated as total size of
attachments minus the non-shared attachment size.

Non-shared
Attachment
Size

Size of attachments that are not shared with other messages.

Internal
Received
Messages

Received messages of type "EX" or "SYSTEM."

SMTP
Received
Messages

Received messages of type "SMTP."

Other
Received
Messages

Received messages not of type "EX," "SMTP," or "SYSTEM."

Note: For a definition of "receivedmessage," see the "Glossary" on page 147.

Messages by Date Report
The Messages by Date report provides statistics for messages in a date range, such as 1/1/2004 to
1/1/2005, and a unit of hours, days, weeks, or months. The report is keyed off of the received date
of the message.

Note: This report is available only for a Priv EDB andCAS files.
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Column Heading Description

Hour/Day/Week/Month The date unit that was selected in the Create Reports window.
Examples are: Hour: "12/25/2004 - 9 PM" Day: "12/25/2004" Week:
"12/26/2004 - 1/1/2005" (Weeks start on Sunday and end on
Saturday.) Month: "12/2004"

Internal Received
Messages

Received messages of type "EX" or "SYSTEM."

Total Size of Internal
Received Messages

The sum of the internal received message sizes.

SMTP Received
Messages

Received messages of type "SMTP."

Total Size of SMTP
Received Messages

The sum of the SMTP received message sizes.

Other Received
Messages

Received messages not of type "EX," "SMTP," or "SYSTEM."

Total Size of Other
Received Messages

The sum of the other received message sizes.

Note: For a definition of "receivedmessage," see the "Glossary" on page 147.

Messages by Profile Folder
The Messages by Profile Folder report provides statistics for messages in a profile folder, the
number of messages, total size of messages, average size of messages, total attachment size,
shared attachment size, non-shared attachment size, internal received messages, SMTP
received messages, and other received messages. The report is keyed off of the profile folder.

Note: The Messages by Profile Folder report only includes information gathered from accessible
mailboxes.

Note: This report is available only for a CAS.
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Column Head-
ing

Description

Profile Folder Title of the profile folder.

Number of
Messages

Total number of messages in the profile folder.

Total Size of
Messages

Total size of all messages in the profile folder.

Average Size
of Messages

Total size of messages in the profile folder divided by number of messages.

Total
Attachment
Size

Total size of attachments in all messages in the profile folder.

Shared
Attachment
Size

Size of attachments that are found more than once, either multiple times
in this profile folder or in this profile folder and other profile folders.

Non-shared
Attachment
Size

Size of attachments that are not shared with other messages.

Internal
Received
Messages

Received messages of type "EX" or "SYSTEM."

SMTP
Received
Messages

Received message of type "SMTP."

Other
Received
Messages

Received messages not of type "EX," "SMTP," or "SYSTEM."

Note: For a definition of "receivedmessage," see the "Glossary" on page 147.
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Sorting Reports
Sorting of reports is available after the reporting process has finished. The order in which statistics
first appear in the Reports window is based on the ascending order of statistics in the first column
(for example, for the Attachment Statistics column, .DOC precedes .TXT). However, you can sort
statistics based on any column heading.

To sort the statistics in a report

1. Click a column heading to sort the statistics based on that heading. An arrow appears
indicating the sort direction. An up arrow indicates the statistics appear in ascending (A-Z)
order. A down arrow indicates that the statistics appear in descending (Z-A) order.

2. To reverse the order of the statistics based on that column heading, click the column
heading again. The arrow reverses directions.

An Example of Sorting

The Attachment Statistics report is originally sorted based on the ascending order of attachment
extensions (for example, .DOC precedes .TXT). If you click the Attachment Extension heading,
the down arrow appears and statistics are sorted in descending order (for example, .TXT
precedes .DOC).

If you click the "Number of Attachments Found in Messages" column heading, the up arrow
appears and statistics are sorted based on ascending order. This means that the attachment
extension occurring least frequently in the data source appears first in the report.

Saving Reports
You may save the currently active report as either a tab-separated or comma-separated text
file. The report name defaults to the name shown on the report tab, without the spaces and with
a .txt extension (for example, MailboxReport.txt). The file type defaults to a tab-separated text
file.

To save a report

1. In the Reports window, make the desired report active by clicking its tab (for example,
Attachment Report, Database Report).

2. Click Save.
3. In the Save Report window, specify the name, location, and file type for the report. You

may save the report as either a tab-separated or comma-separated text file.
4. Click Save to return to the Reports window.
5. Repeat steps 1-4 for each report you want to save.
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Overview
The content analysis store (CAS) enables you to automate and save search results by selecting
sources. Sources include entire EDB files, individual mailboxes from an EDB, or folders from an
EDB. Any number of sources is allowed, including multiple EDBs.

After selecting specific sources, you can create profile folders as subfolders to the content
analysis store. Each profile folder has the same criteria as the search criteria, such as, "From," "To,"
"Subject," etc. Only messages matching the criteria are contained in the profile. Multiple profile
folders are possible. Every profile folder processes simultaneously. This allows you to make many
separate searches (profiles) for the same set of sources.

After the processing is complete, you can open the content analysis store as a source. This allows
you to use the CAS for searching, copying, exporting, and integrity checks. It allows you to copy
the data out of the CAS into PSTs or to a Microsoft Exchange Server. It allows you to repeatedly
use a specific set of profile results without having to rerun the profile processing. The results of the
profile can be saved between sessions using the CAS. You can also save the CAS on one
computer and reopen it on a different computer to share the results of a profile.

Content analysis stores provide a method for an email administrator to perform content analysis
offline from their production server. This feature:

n Minimizes the time it takes to detect/filter out emails that include specific content.
n Minimizes the time it takes to detect/filter out a specific type of email file that is being sent

or received (for example, specific extension, subject, date).
n Analyzes the number of emails being sent/received that contain what could be legally

damaging content (for example, admission of guilt).
n Analyzes the number of emails being sent/received that contain politically incorrect

content (for example, tasteless jokes, pornography).
n Analyzes the number of emails with confidential content that go out unprotected -

unencrypted.
n Minimizes the time it takes to determine if someone is using the system for unauthorized

activity (for example, spamming, inappropriate downloads, starting a business).

Creating a Content Analysis Store
A new content analysis store can be created from the File menu, from the toolbar, or from the
Data Wizard. After the CAS file is created, a new content analysis store shows in the target pane.

To create a content analysis store using the toolbar

1. On the toolbar, click the Create/Open Target Content Analysis Store icon located on
the toolbar. The Opening a Content Analysis File window appears.
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2. Enter a File name and in the Look in box, select a destination.
3. Click Open. The name of the store defaults to the file name you entered in step 2. It can

be renamed as any other target folder.

To open or create a target Content Analysis Store using the menu

1. To display the Opening a Content Analysis File window, on the File menu, point to Open
Target Content Analysis Store and click Open Existing or Create New.

2. If creating a new target CAS, enter a File name and click Open.
3. If opening an existing target CAS, select the CAS from the list and click Open.

To open or create a target Content Analysis Store using the Data Wizard

1. On the File menu, click Use Wizard. The Data Wizard appears.
2. Click Next. The Source Path Selection page opens.

Figure 8-1: Selecting a CAS file in the Source Path Selection

3. In the Source File box, click Browse to find the source EDB you want to search. If you want
to view a filtered display of mailboxes in the Source Pane, use the MailboxCriteria
(optional) box. (For more information, see "MailboxCriteria" on page 34.) If you do not
want to open a source EDB file at this time, click Skip.

4. Click Next. The Target Type & Path Selection page of the Data Wizard appears.
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Figure 8-2: The Target Type & Path Selection window

5. Select Content Analysis Store.
6. Do one of the following:

l If you know the target CAS file path, type it in the Content Analysis Store Path box.
l Click Browse to open the Create Content Analysis Store window, and navigate to the

desired location. Then create a new CAS file by typing a name in the File name box, or
select an existing CAS file. Then click Open. The path of the target CAS file appears in
the Content Analysis Store Path box.

7. Click Next. The Completing the Data Wizard page of the Data Wizard appears.
8. Click Finish.

Creating a Content Analysis Store with Microsoft Exchange
Server 2010 Data
Any source or target content analysis store (CAS) created with Microsoft Exchange Server 2010
data is subject to different handling based on the Recoverable Items preference settings. See
Setting Preferences in "Security Tab".

When a CAS is created, whatever the Recoverable Items preference setting is at that time will
be stored with that CAS. If you attempt to open a CAS as a source or target, the preference
stored in the CAS is checked against the current preference setting. If they don't match, the
following message displays: "The current `Show Recoverable Items (Microsoft Exchange Server
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2010)' preference setting does not match the setting for the Content Analysis Store. The Content
Analysis Store cannot be opened unless its setting is changed. To change the setting the
Content Analysis Store, click `OK.' The Content Analysis Store will be opened as a target and all
profiles will be reprocessed. Click `Cancel' to cancel opening the Content Analysis Store."

Creating and Processing Content Analysis Store Profile
Folders
A content analysis store profile folder is created as a subfolder of the content analysis store to
filter EDB messages (only) based on the profile criteria.

When the profile folder is created, a folder appears under the content analysis store and
ShadowProtect Granular Recovery for Exchange (SPGRE) searches all the sources in the content
analysis store for messages that match the criteria for the profile folder.

During processing (searching), the profile folder is green and its status will indicate that
processing is taking place. The status bar at the lower left also indicates the status. The message
pane on the right populates with the results when the profile folder is selected or when the
screen is refreshed.

Deduplication can be performed on a per profile basis and if selected does not return
duplicates of a message during a search. For example, if the same message exists in two or more
data stores, only the first message found is listed in the search results. Selecting this option may
result in slower search performance.

Note:Only accessible mailboxes in the EDB source can populate the CAS target profile with
messages.

To create and process a content analysis store profile folder

1. Select a target content analysis store root.
2. In the Profile menu on the menu bar, click Create Profile. The Create Profile window opens

with "Profile1" as the default Profile Name. Once created, the content analysis store profile
folder can be renamed just as any folder would be.

3. Enter the criteria for the content analysis. This window offers similar search options as the
Find window. For more information, see "Finding Messages".

Note: The profile criteria can be saved and imported.
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Figure 8-3: The Create Profile Folder window is used to enter profile criteria

4. Click OK. SPGRE indicates that a profile is processing when the color of the profile folder is
green and its status states "Processing." When the profile is selected, the status shown in the
status bar at the lower left of the main window indicates that the profile is processing. For
more information, see "Profile Processing Statuses".

5. When the processing for a profile is complete, the color of the profile icon changes from
green to blue and its status states "Completed." All messages from the content analysis
store EDBs that match the criteria are contained in the profile folder.

Note: A content analysis store cannot be opened as a source until all profile processing
has completed.

Figure 8-4: Messages displayed after profile folder created

Note: If the same source is added to the content analysis store twice for processing,
SPGRE ignores the second copy. The source is not listed twice nor is an error message
displayed.
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DB # Column
The content analysis store profile folder message views include a column to display a database
number to enable you to trace back to the actual database in the content analysis store. This
number does not correlate to the profile folder number or source #, i.e., "Profile1" or "Source 1"
does not necessarily correlate with DB #1. The correlation is between the profile folder message
and the source database.

Example:

Figure 8-5: The Database numbers are tied to the actual database.

Note: Database (DB) numbers are tied to the actual database, not the folder so each folder
from the same EDB will have the same DB number. DB numbers increment from 1 for each
different database added to the content analysis store, not for each folder.

Profile Processing Statuses
When the profile is processing, there are four possible statuses that are displayed: Processing,
Suspended, Completed, andCompleted with errors.

Figure 8-6: Profile Processing Status folders are indicated by different colors

Processing
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After entering the profile criteria, the profile is created and is represented by a folder under the
content analysis store. During processing (searching), the profile folder is green and its status
states "Processing." Selecting the profile folder or pressing F5 populates the message pane with
messages when the processing is complete.

Processing occurs when a new profile is created, when removing a source, when adding a
source, when editing a profile, when copying a source profile folder to a target content analysis
store, or when resuming a suspended profile.

Note: If unrecoverable errors are encountered during processing then the profile is not fully
processed and is blue in color with a red ! indicating the error.

Suspended

Processing can be suspended (see "Suspending and Resuming Content Analysis Store Profile
Folders" on page 128) on any profile folder during processing. Suspended profile folders are red in
color. The status also indicates that the profile is suspended.

Completed

Once the processing is complete, the profile folder turns blue and its status states "Completed."

Completed with errors

If SPGRE detects corruption or some other issues while processing, the profile folder status states
"Completed with errors." To obtain details on the error, view the Properties on the profile folder by
right-clicking on the profile folder and selecting Properties.

Figure 8-7: An error message displays when processing cannot be completed

Saving and Importing Profile Criteria
Profile criteria can be saved and later imported into a new profile in the Create Profile window
to save time.
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To save a profile criteria

1. On the File menu, click Save Criteria.
2. In the Save As window, enter a File name and click Save. Be sure to note where the criteria

file is being saved in the Look in: box.

Note: The profile folder name is not saved.

To import saved profile criteria

1. On the File menu, click Use Previous Criteria.
2. In the Open window, select the previously saved profile criteria .txt file.
3. Click Open. All previously saved profile criteria, except for the Profile Name, reads from

the file and is placed into the Create Profile fields.
4. Enter a new Profile Name.

Note: Search criteria from previous and current versions of SPGRE can be imported into
SPGRE for find and profile criteria.

Suspending and Resuming Content Analysis Store Profile
Folders
You can pause the processing of one or more profile criteria folders and then resume processing
at a later time. Suspended profile folders are red in color and then turn to green when processing
is resumed. The folder then turns to blue when processing is complete. For more information, see
"Profile Processing Statuses".

Important: Processing of all profiles is suspended automatically if you exit SPGRE or if you close
the content analysis store before processing is complete.

To suspend the processing on profiles

n Do one of the following:

l Select the profile folder, click the Profile menu and click Suspend Processing.
l Right-click the profile folder and click Suspend Processing.

To suspend processing on all profiles

n Do one of the following:

l Select the content analysis store root, click the Profile menu and click Suspend
Processing.

l Right-click the content analysis store root and click Suspend Processing.

Note: Suspended profiles are red in color. The status also indicates that the profile is suspended.
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To resume processing on profiles

n Do one of the following:

l Select a profile folder, click the Profile menu and click Resume Processing.
l Right-click the profile folder and click Resume Processing.

To resume processing of all profiles

n Do one of the following:

l Select the content analysis store root, click the Profile menu and click Resume
Processing.

l Right-click the profile folder and click Resume Processing.

Adding Sources to Content Analysis Stores
Only EDB store objects, EDB mailboxes, or EDB folders can be drag and dropped or copied and
pasted from the source into the new content analysis store root to prepare for analysis.

If you open a source with a set of mailbox criteria, create a CAS using that source, then close
and re-open the source with different mailbox criteria, no additional folders or mailboxes can be
added from that source. Re-open the source with the matching mailbox criteria or remove all
references to the original source before re-adding.

Note:Messages or folders cannot be copied directly to a profile folder (results folder).

To add a folder, a mailbox, or an EDB file with copy-paste

1. In the source pane, select a folder, a mailbox, or an EDB file.
2. Do one of the following:

l On the Edit menu, click Copy.
l Right-click the selected item(s), and on the shortcut menu, click Copy.

l Click the Copy Mail Item icon on the toolbar.
l PressCtrl+C (Copy).

3. In the target pane, click the content analysis store root and do one of the following:

l On the Edit menu, click Paste.
l Right-click the selected item, and on the shortcut menu, click Paste.

l Click the Paste icon on the toolbar.
l PressCtrl+V (Paste).

4. In the Copy Progress window, verify that your messages were successfully copied, and
click Close.
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To add data even faster, use drag-and-drop

n To move entire EDB store objects, EDB mailboxes, or EDB folders, drag to the target
content analysis store root. Dragging and dropping achieves the same results as copying
and pasting.

To use drag-and-drop when right-clicking a source item

1. In the source pane, select one or more messages.
2. Right-click the selected message containers and drag them to a content analysis store in

the target pane.
3. When you let go of the mouse, a shortcut menu appears. On the shortcut menu, click

Paste.

Important: If a new source (Inbox, Deleted items, Outbox, etc.) is dropped into the
content analysis store or the user removes a source store from the content analysis store,
all profiles automatically process the new source.

Editing and Deleting Profiles
Deleting a profile stops any processing on that profile and removes that profile and all data
associated with it from the content analysis store. Deleting a profile does not modify the EDB
sources.

To edit a profile

1. To edit a profile, right-click the profile folder and click Edit Profile or click on the Profile
menu and click Edit Profile.

2. The Edit Profile Folderwindow appears. Edit any or all of the criteria. When new criteria is
entered, all messages in the profile are deleted, the icon changes to its processing color
(green), the profile status will update, and the process begins.

To delete a profile

n Do one of the following:
l Right-click the profile folder and click Delete.
l Click profile folder, and on the Edit menu, click Delete.
l Select the profile folder and press the Delete key on the keyboard.

Closing a Content Analysis Store
Closing a content analysis store root closes the root as well as all of the profile folders created
under that root.
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To close a content analysis store (CAS)

n Do one of the following:
l Right-click the CAS and click Close Store.
l Click the CAS and on the File menu, click Close Store.

Opening a Content Analysis Store as Source
When all profile processing has completed, you can open the content analysis store as a source,
for which the following source operations can be performed: Copy/Paste, Paste Special, Export,
Find, Integrity Check, Properties, and Create Reports. Use copy/paste to copy source profile
search criteria to a target content analysis store.

If a content analysis store is opened as a source and it has not completed processing all profiles,
a window indicates that the content analysis store has not completed its processing. There is
then an option to open the CAS as a target. If that option is selected, SPGRE opens it as a target
and resumes processing on all remaining profiles.

To open a content analysis store as source

1. One the File menu, click Open Source. The Select Source Files dialog box opens.

Figure 8-8: The Source Source Files dialog boxis used to open aCAS as source

2. Click Browse to the right of Source File (*.edb, *.pst, *.cas).
3. In the Open dialog box, select a .cas file and click Open.

131



Chapter 8: Content Analysis Store

4. In the Select Source Files dialog box, click OK. A source content analysis store appears in
the left pane of source.

Figure 8-9: A source content analysis store root and profile folders

Viewing Properties of a Content Analysis Store
To view the properties of a content analysis store

n To display the CAS File Properties window, right-click the CAS in either the source or target
pane and click Properties.

Figure 8-10: The Properties of the selected CAS file

To view the properties of a content analysis store profile folder

n Right-click the profile folder and click Properties.
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Figure 8-11: The Properties of the CAS profile folder

Creating Reports in Content Analysis Store
You can create reports of the source content analysis store by right-clicking the source content
analysis store root. The reports are:

n Attachment statistics
n Domain statistics
n Messages by Database
n Messages by Profile Folder
n Messages by Date

See "Reporting" for instructions on creating reports.

Viewing Profiles in Content Analysis Store
The Viewing Profiles option allows you to view what profile criteria has been used for a specific
content analysis. All fields are read only.

To view a profile

1. Do one of the following to display the Profile Folder Properties page:
l Right-click the profile folder in either the source pane or target pane and point to View

Profile Folder.
l Click the profile in either the source pane or target pane, click the Profile menu and

click View Profile Folder.
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Figure 8-12: Profile Folder Properties

2. Click OK to exit.

Missing Database Files
If an EDB or log file that belongs to a content analysis store is moved and then the content
analysis store is opened, there is a prompt to find or remove the missing database files. If the EDB
is located but the STM is missing, SPGRE displays an error indicating that the STM needs to be
located in the same directory as the EDB.

Missing EDB
When there is a wrong EDB, you are prompted to locate the file.
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To locate the missing EDB

1. On the Missing Database File error message, click Browse. The Open window appears.
2. Navigate to the EDB files and double-click the appropriate file.
3. Click OK. The source pane now populate with files.
4. If you are unable to locate the EDB file, click Remove on the Missing Database File error

message. A message asking you to confirm your decision to remove the file is displayed.
5. Click OK.

Important: When an EDB is removed, the complete source EDB is removed from the CAS
as well as any source folders or mailboxes that also reference that EDB.

Missing Log Files
When there are missing log files, you are prompted to locate the log directory. The Browse
button opens a Browse for Folder dialog and defaults to the last known location of the logs.

To locate missing log files

1. On the Missing Database File error message, click Browse. The Open window appears.
2. Navigate to the directory containing the logs and click OK. The source pane now

populates with files.

Important: When logs are removed, the complete source EDB is removed from the CAS as
well as any source folders or mailboxes that also reference that EDB and logs.

Missing STM Files
When there are missing .stm files, you are prompted to remove the files.

To remove missing .stm files

1. On the Missing Database File error message, click Remove.
2. A message asking you to confirm your decision to remove the file is displayed. Click OK.

Important: When the .stm is removed, the complete source EDB is removed from the CAS
as well as any source folders or mailboxes that also reference that EDB and .stm.

Missing Temp Files Directory Location
When there are missing temp file directory locations, you are prompted to locate the temp file
directory location. The Browse button opens a Browse for Folder window and defaults to the
current temporary path set by SPGRE.

To locate missing temp file directory location

1. On the Missing Database File error message, click Browse. The Open window appears.
2. Navigate to the directory containing the temp files.
3. Click OK. The source pane now populates with files.
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Note: If just the temp files are missing but the directory exists, it recreates the temp files.

Wrong Database Files
When SPGRE finishes opening the EDB, it checks the database for the correct file in the content
analysis store. If it does not locate the correct file, it determines that there is a different EDB at
the original location than when the CAS was originally created. An error is displayed and
prompts you to remove the file from the CAS.

To remove wrong files

1. On the Wrong Database File error message, click Remove.
2. A message appears asking if you are sure you want to remove the source and all related

messages from the content analysis store. Click OK.

Upgrading from a Previous Version
If you attempt to open a content analysis store created with a prior version of SPGRE, you will be
prompted to upgrade the content analysis store. After the upgrade process, the content
analysis store will no longer be compatible with a prior version of SPGRE. For this reason, it is
recommended that you make a copy of the content analysis store before upgrading it.

To upgrade the content analysis store

1. Open the content analysis store you want to upgrade, either as a source or a target.
2. A message appears asking if you are sure you want to upgrade the content analysis store.

Click OK.
3. The content analysis store opens as a target and all sources in the content analysis store

are opened. If any database files are missing, you will be prompted to browse for the
missing files. See the "Missing Database Files" for more information.

4. After the content analysis store has been opened as a target, all profiles are reprocessed.
5. Once the content analysis store is opened as a target, it has been upgraded and can no

longer be opened with a previous version of SPGRE.
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Overview
You can view all instances of a given message or attachment in the EDB source(s) within the
same database as well as messages related by conversation in the Message Views option. This
option is particularly useful in assisting with administrative tasks such as database cleanup
activities, determining the history or dissemination of a message, or grouping messages by
conversation thereby allowing you to view them together in context without missing a reply or
forward.

Message views are available for messages in the source pane, find results pane, and also from
another message view. Message views are available only on single messages. If multiple
messages are selected in the message pane, the message view menu items and toolbar buttons
are unavailable.

You can view a message in various ways, depending on the message view option selected.
Upon option selection, you are presented the following:

n Message Table View - all the messages that are referenced by the same message table
row as the selected message.

Note: The Message Table View does not support Microsoft Exchange Server 2007 and
Microsoft Exchange Server 2010 EDB sources as Microsoft stopped supporting single
instance storage with Microsoft Exchange Server 2007.

n Attachment Table View - all the messages that have an attachment that are referenced
by the same attachment table row as the selected attachment.

Note: The Attachment Table View does not support Microsoft Exchange Server 2007 and
Microsoft Exchange Server 2010 EDB sources as Microsoft stopped supporting single
instance storage with Microsoft Exchange Server 2007.

n Conversation View - messages that are related by conversation, with the sorting order of
the email thread based on who replied to whom within the thread. Messages are
indented to show the thread timeline of when replies occurred.

Note: If you use the "MailboxCriteria (optional)" box on the Select Source Files dialog box or the
Source Path Selection page of the DataWizard, only EDB mailboxes containing your entry (or
entries) are displayed on the Source Pane. Anymailboxes which do not match the entered string
(s) will not appear in the Source Pane andwill not be included in any subsequent tasks (such as
searching, copying, and exporting of the entire database). For more information, see "Mailbox
Criteria" on page 34.
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Message Views Menus and Toolbars
The message views are accessible via the Tools menu, toolbar buttons, and a sub-menu on the
shortcut menu in the message panes.

Message Views Menus
The Tools menu contains a sub-menu with menu items for each message view.

Figure 9-1: The Tools menu leads to the Message Views options

Message Views Toolbar Icons
A toolbar button exists for each message view: Message Table View, Attachment Table View,
and Conversation View.

Figure 9-2: The toolbar provides another option for accessing the Message Views

Message View Shortcut Menu
The source pane shortcut menu has a Message Views sub-menu with menu items for each
message view. As with the main menu, the new Message Views menu items provides status bar
text when they are highlighted.
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Figure 9-3: The Message View options can be reached by right-clicking an EDB message in the
upper message pane.

Figure 9-4: The Status Bar

Message View Pane
The Message View Pane is the area that hosts the various message views. The pane provides you
the ability to view the related messages and perform various actions (for example, viewing
messages in alternate views, exporting messages to your directory, checking the integrity).

Other Options Available in the Message View
Other actions can be performed within a Message View, such as Exporting messages, Integrity
Check, copying messages, and viewing a message in another Message View.

Figure 9-5: Other options available in the Tools menu are Copy, Export, and Integrity Check

These options are available in any Message View:
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n Copying Messages-Messages within a Message View can be copied and pasted into
folders in the target pane via the Edit menu or shortcut menu. For more information about
copying messages, see "Restoring Microsoft Exchange Server Data" on page 85.

n Exporting Messages-Messages within a Message View can be exported as any message
can via the Tools menu or shortcut menu. For more information, see "Exporting Messages"
on page 76.

n Integrity Check -Messages within a Message View can have an integrity check performed
on them via the Tools menu or shortcut menu. For more information, see "Looking at the
Interface" on page 7.

n Message Views -Messages within a Message View can be viewed in any of the three
Message View options, Message Table View, Attachment Table View, or Conversation
View. The message view options are only available if a single message is selected.

Message View Options
You have the option of viewing all instances of a given message or attachment in the EDB
source(s) in three different ways-Message Table, Attachment Table View, and Conversation
View.

Note: The Message Table and Attachment Table Views do not support Microsoft Exchange
Server 2007 andMicrosoft Exchange Server 2010 EDB sources as Microsoft stopped supporting
single instance storage with Microsoft Exchange Server 2007.

Message Table View
Choosing the Message Table View option displays all the messages from the same EDB that
reference the same message table row (Single Instance Storage).

Note: The Message Table View does not support Microsoft Exchange Server 2007 andMicrosoft
Exchange Server 2010 EDB sources as Microsoft stopped supporting single instance storage with
Microsoft Exchange Server 2007.

Example:

Amessage is sent to User1, User2, and User3. The message is stored in the message table once. If
a user opens up the database and right-clicks the message in User1's Inbox and chooses
Message Table View, a table opens with three messages in it: One in User1's Inbox (or deleted
items), one in User2's Inbox, and one in User3's Inbox as long as they are all in the same Microsoft
Exchange Server database (EDB). If User 1, 2, or 3 are in a different EDB, those messages will not
appear in this view.

Sample
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Figure 9-6: The Message Table View displays messages that have been deleted.

The message pane displays the related messages in a report format showing the Message Type,
Attachment, From, To, Subject, Folder, Date, and Status (indicating if message has been
deleted).

Note:Onlymessages within the same EDB can be viewed in the Message Table View.

To open and view messages in the Message Table View

1. In the message pane, select an EDB message.
2. Do one of the following to display the Message Table View:

l Click the Message Table View icon on the toolbar.
l Right-click a message and point to Message Views, then click Message Table View.
l Click the Tools menu, point to Message Views, then click Message Table View.

Note: The first time opening a view on this EDB, amessage appears stating that aMessage View
file needs to generated.

Attachment Table View
Choosing the Attachment Table View option displays all of the messages in the same EDB that
have an attachment referencing the same attachment table row as the selected attachment
(Single Instance Storage). If the message contains multiple attachments, a sub-menu listing
each individual attachment allows the selection of an individual attachment.

Note: The Attachment Table View does not support Microsoft Exchange Server 2007 and
Microsoft Exchange Server 2010 EDB sources as Microsoft stopped supporting single instance
storage with Microsoft Exchange Server 2007.

Example:

Amessage with an attachment is sent from User1 to User2 and User3. User3 forwards the email to
User4. The attachment is stored in the attachment table only once (single instance storage). A
user opens up the Microsoft Exchange Server database (EDB) containing these messages and
creates an Attachment Table View on the message in User's "Sent Items" folder. The Attachment
Table View contains five messages: one in User1's Sent Items, one in User2's Inbox, one is User's
Inbox, one in User3's Sent Items and one in User4's Inbox as long as they are all in the same EDB.

141



Chapter 9: Message Views
As in the Message Table View, the Attachment Table View shows the related messages in a
report format with Message Type, Attachment, From, To, Subject, Folder, Date, and Status
(including indicating if message has been deleted).

Note:

l Onlymessages with attachments can be viewed in the Attachment Table View.
l Only attachments within the same EDB can be viewed in the Attachment Table View.
l Attachments within inaccessible mailboxes cannot be viewed in the Attachment
Table View.

To open the Attachment Table View

1. In the message pane, select a message.
2. Do one of the following to display the Attachment Table View:

l Click the Attachment Table View icon on the toolbar.
l Right-click a message and point to Message Views, then click Attachment Table View.
l Click the Tools menu, point to Message Views, then click Attachment Table View.

Note: The first time opening a view in this EDB, amessage appears stating that aMessage
View file needs to generated.

Figure 9-7: The Attachment Table View displays messages with attachments

3. To view a message within the Attachment Table View, right-click a message, point to
Message Views and select one of the following options:
l Message Table View
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l Attachment Table View
l Conversation View

4. Any message in the Attachment Table View can be opened by double-clicking the
message in the table.

Conversation View
Choosing the Conversation View option displays the messages that are related by conversation
showing the Message Type, Attachment, From, To, Subject, Folder, Date, and Status (including
indicating if message has been deleted). Messages are indented to show the chain of replies
and forwards.

Example:

If a user composes and sends Email 1 to another user, and that user sends Email 2, a reply to Email
1, then Email 1 has no indention and Email 2 is indented one level. If the first user then replies to
Email 2 with Email 3, then Email 3 is indented two levels.

Note:

n Only conversation threads within the same EDB can be viewed in the Conversation View.
n Messages within inaccessible mailboxes cannot be viewed in the Conversation View.

To open a Conversation View

1. In the message pane, select a message.
2. Do one of the following to display the Conversation View:

l Click the Conversation View icon on the toolbar.
l Right-click a message and point to Message Views, then click Conversation View.
l Click the Tools menu, point to Message Views, then click Conversation View.
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Figure 9-8: The Conversation View displays the conversation threads which are indicated
by indentations.

Note:

l The first time opening a view on this EDB, amessage appears stating that aMessage
View file needs to generated.

l If the first message is missing, the next message in the thread is still indented indicating
that it is not the original message.

3. To view a message within the Conversation View, right-click a message, point to Message
Views and select one of the following options:
l Message Table View
l Attachment Table View
l Conversation View

4. Any message in the Conversation View can be opened by double-clicking the message in
the table.

Opening a View for the First Time
To create a Message View for the first time

1. The first time you create any Message Table View, Attachment Table View, or
Conversation View, ShadowProtect Granular Recovery for Exchange (SPGRE) creates a
Message View file. If no file exists, you are prompted to create the file.
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Figure 9-9: This message informs the user that an initial message view file does not exist

2. Click Yes to create the file. A progress window is displayed to indicate the stage, progress
text, estimated time, elapsed time, and a grow bar.

For Microsoft Exchange Server 2007 and earlier, there are 5 stages: Initializing file,
Processing attachments, Processing messages, Processing rows, and Saving file.

For Microsoft Exchange Server 2010, there are 3 stages: Creating the file, processing the
conversation messages, and saving the file.

After the message view file has been created, if creating a Message Table View, the
Creating Message View File progress window is replaced by another progress dialog that
tracks the progress of view preparation. A Preparing Message Table View progress window
appears.

If you click Cancel during this process, the Message Table View is not shown.

3. To view a message within the Message Table View, Attachment Table View, or
Conversation View, right-click a message, point to Message Views and select one of the
following options:
l Message Table View
l Attachment Table View
l Conversation View

4. To open a message in the Message Table View, Attachment Table View, or Conversation
View, double-click on the message in the table.

Find in Source Window in Message Views
You can open a message view from the Find in Source window by using the Message Views sub-
menu on the Find Window's top-level Tools menu. The messages in the Find in Source window's
results pane also have the Message Views shortcut menu by right-clicking on a message and
pointing to Message Views.

Note: The Attachment Table View does not support Microsoft Exchange Server 2007 and
Microsoft Exchange Server 2010 EDB sources as Microsoft stopped supporting single instance
storage with Microsoft Exchange Server 2007.
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To open messages in Find in Source window result pane in different views

1. Click the Find icon on the toolbar. The Find in Source window is displayed.
2. Enter search criteria in the appropriate fields.
3. Click Find Now. The Results pane appears with the search results.

Figure 9-10: The Find results can be displayed in each of the Message Views

4. Do one of the following:
l Click the Tools menu, point to Message Views, then click the desired view in the sub-

menu.
l Right-click the message, point to Message Views, then click the desired view in the

sub-menu.
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Term Description

Attachment
Table View

A table that displays all the messages that have an
attachment referenced by the same attachment table
row as the selected message.

CAS See Content Analysis Store

CHK Checkpoint files (.chk files) are used for recovering
(playing) data from transaction logs into EDB files. The
checkpoint is the place marker in the EDB.CHK file that
indicates which transactions have been committed.
Whenever data is written to an EDB file from the
transaction log, the EDB.CHK file is updated with
information specifying that the transaction was
successfully committed to the respective EDB file.
Separate Exx.chk files are maintained for each storage
group using ESE (Extensible Store Engine).

Content
Analysis Store
(CAS)

A data store type where each message in the root level
container identifies a source container. A source
container can either be an EDB, an EDB mailbox, or an EDB
folder. The CAS is used to analyze messages based on
profile criteria entered before processing.

Conversation
View

A table that displays all messages in the database that are
related by conversation. The conversation thread is
indented to indicate replies.

Data Store A unified collection of folders and messages contained in
a single storage medium. A PST file is a data store. A
Microsoft Exchange Server Information Store is also a data
store. In a basic case, Microsoft Exchange Server has two
live data stores, one for the private mailboxes and one for
the public folders.
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Term Description

Data Wizard The first time you start ShadowProtect Granular Recovery
for Exchange (SPGRE), the Data Wizard starts. The Data
Wizard guides you through the loading of Microsoft
Exchange Server Database (EDB), PST files, or content
analysis store (CAS) files into SPGRE, and shows you how to
specify the target PST file or Microsoft Exchange Server.

Deduplication Deduplication is performed on a per profile basis and if
selected does not return duplicates of a message during a
search. For example, if the same message exists in two or
more data stores, only the first message found is listed in
the search results.

EDB See Microsoft Exchange Server Database.

EIS See Microsoft Exchange Server Information Store.

Log Files Transaction log files (.log files) are history files recording
server activity. These files are useful in restoring and
backing up Microsoft Exchange Server data. Transaction
logs for Microsoft Exchange Server 5.5, 2000, and 2003 are 5
MB in size. Transaction logs for Microsoft Exchange Server
2007 and 2010 are 1 MB in size.

Messages Messages are found in the folders of a Microsoft Exchange
Server Information Store. Messages can mean "email," but
Microsoft Office Outlook Contacts are also messages, as
are Appointments, Journal Entries, Sticky Notes, and Tasks.

Message
Table View

A table that displays all messages that are referenced by
the same message table row as the selected message.
For example: A message that is sent to three different users
is displayed three times, one in each users Inbox.

Microsoft
Exchange
Server
Database

This file, which usually has an EDB extension, contains the
mailbox, folders, and messages you see when connecting
to a Microsoft Exchange Server. The Microsoft Exchange
Server reads and writes to this file in response to incoming
email and events from the clients. On Microsoft Exchange
Server 2000, this is one of the two files that make up the
Microsoft Exchange Server Information Store, the other
being the STM file.
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Term Description

Microsoft
Exchange
Server
Information
Store

This is the set of files that make up the data store for private
mailboxes and public folders on a Microsoft Exchange
Server. For Microsoft Exchange Server 5.5, this is the single
Microsoft Exchange Server Database file usually named
priv1.edb and pub1.edb. On Microsoft Exchange Server
2000, 2003, 2007, and 2010, the private mailbox data store
will consist of the files priv1.edb and priv1.stm, and the
public folder data store will consist of pub1.edb and
pub2.stm.

PAT Patch files (.pat files) are used to record information on
page splits in Microsoft Exchange Server 5.5 through
Microsoft Exchange Server 2000 (SP1). In Microsoft
Exchange Server 2000 (SP2) and later, the functionality
provided by .pat files is incorporated into Microsoft
Exchange Server log files.

Profile Folder A subfolder of the content analysis store containing the
results of profile criteria entered for processing.

PST Personal Storage file. This file, used by Microsoft Office
Outlook, contains folders and messages that have been
retrieved from a user's Microsoft Exchange Server mailbox
and copied locally.

Received
Messages

Messages that have been sent through a Microsoft
Exchange Server to another mailbox. Messages in the
"Sent Items" folder are copies of messages sent through a
Microsoft Exchange Server and are not considered to be
"received messages." Because messages in the "Drafts"
folder, "Notes" folder, and other similar items are not sent
through a Microsoft Exchange Server, they too are not
considered to be "received."
Note: Because recovery software such as SPGRE restores
messages from a source to aMicrosoft Exchange Server
mailboxwithout sending them, the messages that SPGRE
restores are not considered to be "receivedmessages."

Shortcut Menu This menu is accessed by right-clicking on an item.
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Term Description

Source Data
Store

This is the data store from which folders and messages are
copied. The source is read-only, so items cannot be
copied into, deleted from, or changed in the source.

STM For Microsoft Exchange Server 2000 and 2003, this is one of
the two files that make up the Microsoft Exchange Server
Information Store, the other being the EDB file. The STM file
stores certain data for emails that come into the Microsoft
Exchange Server through the POP or SMTP port. This email
data may eventually get moved into the EDB file over
time.

Target Data
Store

This is the data store to which folders and messages are
copied. The target is read-write allowing items to be
added, deleted, and changed. The target data store can
be a Microsoft Exchange Server or PST file.
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opening 42
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the preview pane 13
the source database and target
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P
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PAT 149
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preview pane
displaying a message in 13
hiding 13
opening 13
opening attachments in 14
saving attachments in 15

previewing and opening messages 13
previous search results

viewing 68
processing

content analysis store profile folder 124
processing on profiles

resuming 129
suspending 128

profile folder 149
properties of an EDB file, PST file, CAS file,

CAS profile folder, mailbox, or folder 17
PST 149
PST and folder limits 86
PST export 77
PST file

creating a new target 36
in source pane 35
opening an existing target 36
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PST files
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generate 81
generated 82
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